The latest version of the official map editor for C&C 3: Kane's Wrath. Please note: You must update Kane's Wrath to patch 1.01 or newer for this latest version of Worldbuilder to function correctly.

C&C 3: Kane's Wrath Worldbuilder v1.1

Related to Mapping Tool

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account: