Fixes the error in Expanded Wars: Federation Rising 1.0. You need The previous version in order to run this.

Expanded Wars Federation Rising 1.01 Patch

Related to Patch

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account: