Allows you to downgrade your Starcraft installation to most any patch version. The last release of STF requires Brood War 1.15.1 to function. Coded by Farty.

SC Downgrader v3

Related to Installer Tool

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account: