This patch fixes some of the issues that occured in Shockwave 0.95. This also adds various new goodies, such as new maps, abilities and units. This REQUIRES Shockwave Version 0.95. Note: A clean install always helps if your having issues. Just remember, install Generals, ZH, ZH 1.04, SW 0.95, SW 0.951 in that order. If the problem persists, visit the forum for support

Shockwave 0.951 Patch for PC

Related to Patch

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account: