Compatible with Starcraft Brood War 1.14 *only*. Use the SC Downgrader tool to quickly and easily set your version of Starcraft to 1.14. For more info, view the extended description.

STF 2.4.4

Related to Full Version

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account: