The mic60setup.exe file you have requested: Tools and Utilities / Utilities / Make it Compatible! v6.0 - 1.19mb is not available. Perhaps try browsing all files for the game Quake III Arena and upload any files you want to share or are missing. This is the only information we could locate:

Make it Compatible! v6.0 (c) 2000-2001 Fragging Information -------------- Sometimes it's better to start the old Point Release v1.17. Think about Mods that are currently not available for v1.27g/h! Or still the normal Quake III A Quake III Arena 1.17 to 1.27g/h Point Release switching utility.

We recommend you return to the download list and browse the links from there. If the problem persists, contact us with the details.

More games