The ah2015t2016.exe file you have requested: Official Patches / v2016 / Aces High II v2.01.5 to 2.01.6 Patch - 268.6kb is not available. Perhaps try browsing all files for the game Aces High and upload any files you want to share or are missing. This is the only information we could locate:

Aces High II Version 2.01 patch 6NOTE: AH2 requires DirectX 9. If you are using an older version of DirectX,you will need to upgrade. Go to Microsoft.com to update.AHII will encounter problems and graphic anomolies when usi Aces High II Version 2.01 patch 6NOTE: AH2 requires DirectX 9. If you are using an older version of DirectX,you will need to upgrade. Go to Microsoft.com to update.

We recommend you return to the download list and browse the links from there. If the problem persists, contact us with the details.

More games Add game