Don't have an account? Join now...

The commonweaponspackv2.5.zip file you have requested: The Outdated Abyss / Elminster's Common Weapons Pack - 2.09mb is not available. Perhaps try browsing all files for the game Star Trek: Bridge Commander and upload any files you want to share or are missing. This is the only information we could locate:

Here is a sneak preview of the weapons that will be needed for Elminster's upcoming Dominion Wars Ship packs. Weapons for all the major Dominion Wars powers will be represented. This will be the standard resource for any future Hardpoints and Mod Packs, so this will be a requirement in the respective readme files. This is a new upgrade for the weapons, torpedos and sound fx that were in the Galaxy Class Mod Pack and the Sol Multisystem 2 Mod.The Torpedo spread scripts require ATP3 (Supplied by MPMP2). So if you do not have ATP3 installed, the Torpedos will fire as normal.Check it out...

We recommend you return to the download list and browse the links from there. If the problem persists, contact us with the details.

More games Add game