Star Trek: Armada II

Activision |

Follow 68

Patch 3.2.6 is only compatible with a previous 3.2.x installation. Patching an earlier version (3.1.5 and below) will result in a corrupt installation. This is an intermediate patch to update Fleet Operations to work with the newest Tunngle clients.

Star Trek Armada II: Fleet Operations 3.2.6

Related to Patch

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account: