Battlefront Extreme BFX

Star Wars Battlefront II mod |

Follow 53

Not my mod just one I had from when filefront closed and I wanted others to be able to play it. Should work just fine if you install to your star wars battlefront 2 directory. Steam directory is as follows Computer/C drive/programfiles(x86)/steam/steamapps/common/StarWarsBattlefront2 Im pretty sure you need the convo pack and the 2.2 patch for this to work.

10 ratings - share yours:

Sort

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account:

  • Arc77FordoM10 Arc77FordoM10

    Hi to whomever reads this. I have been playing this mod forever but recently I wanted to change something about it. When Disney killed off Han Solo I started to crave for playing as him in this mod all the time but what bothers me is that his standard rebel DH-44 Blaster is too weak and has a ridiculous cooldown. I know that I have to change something in the sides, namely in the all.lvl file, to alter weapon properties. Unfortunately everything is encrypted and I have no idea how to do it. So if anyone has an idea how to edit the files to change weapon stats I would be extremely grateful if you could help me. I am definitely going to continue to play BFX so if you read this post long after I wrote it don't hesitate to reply- Cheers!

    Reply
    2 +
    • vaders_Legion vaders_Legion

      takes skill to use. more so than other guns in there.

      Reply
      +
    • Ungeheuer1 Ungeheuer1

      Nothing is "encrypted." It has all been compiled from the source code. When you open it, you're probably looking at it with an ascii or UTF encoding, so none of it makes sense. Even if you got a binary text editor, it still wouldn't make sense. You would need the source files to make any edits.

      Reply
      +
  • AgentDennis46 AgentDennis46

    Is this compatible with the Conversion pack?

    Reply
    +
    • Dew-itStewart Dew-itStewart

      As it says in the description, it's actually a requirement

      Reply
      +
      • LOCKJAWVENOM LOCKJAWVENOM

        That description is false. Convo pack and BFX are completely separate mods and you don't need one to install the other.

        Reply
        3 +
  • gamerdude0072 gamerdude0072

    How do i get this to work with the vanilla eras for custom maps and campaign?

    Reply
    +
    • Velrav Velrav

      You dont. The new Eras are hard scripted for the skirmish maps.

      Reply
      +
  • Flyboy189th Flyboy189th

    Followed steps to setup, no mod shows up. Does it need to have "GameData" attached at end or not?

    Reply
    +
  • #0Guest Guest

    This comment is currently awaiting admin approval, join now to view.