Classic Doom 3

Doom III mod |

Follow 353

This version of Classic Doom 3 is compatible with all supported operating systems and distribution platforms (Windows, Linux, Mac) and address a large number of issues that arose with the release of Doom 3 1.3.1 and the Classic Doom 3 patch 1.2. Cdoom3 1.3.1 is a complete package so you must remove any previouse instances of this mod before you attempt to run version 1.3.1.

Classic Doom 3 1.3.1

Related to Full Version

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account: