Mayhem

X³: Terran Conflict mod |

Follow 6

The E/I module is sometimes necessary to update your previous Mayhem savegames. Please read the full instructions. Install in X3\addon\scripts.

Mayhem Export Import 1.04

Related to Plugin

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account: