Star Wolves 3: Expansion Mod. (SW3EXP)

Star Wolves 3: Civil War mod |

Follow 7

To some a clusterfuck of features, to others the only way to make this game any more worth-while, to me? a sandbox. For more Information, visit the SW3EXP Thread @ the 1C Forums. Can't post a link, since seemingly someones got a problem with that, what a shame.

Sort

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account:

  • martix martix

    Hey, just discovered this mod. Looks neat.

    The mouse fix however doesn't work. I do have a high end machine and tried setting the FPS limit to anything from 60 FPS to 250(my monitor's 165).

    Also, trying to dock with some weird "Market trader" in the beginning CTDs the game.

    Reply
    +
    • nocalora nocalora Creator

      Thats strange... the the whole reason why the game escalates the mouse is because of the fps. I would recommend to use a program like Nvidia Inspector (if you have an nvidia graphics card) to limit your systems fps to 60 temporarily if you still want to avoid having mouse problems.

      As for the CTD; that just doesn't make sense to me at all as to why that would happen, but thanks for the info. Im gonna see if I can replicate it somehow.

      Reply
      2 +
      • martix martix

        My mouse is Logitech G500s. Maybe it's something with the drivers or the software it uses for button and DPI profiles, who knows.

        Reply
        +
  • #8Guest Guest

    Hi!

    I'm downloading "[FULL] Expansion Mod [0.6.1.9P2RC9]" at 0,00 b/s. I tried several mirrors. I'm pretty intrested in this mod though; about to start a new run.

    Any ideas?
    E.

    Edit: PS: Using Chrome, i've had no issues before with downloading any kind of files.

    Reply
    0 +
    • nocalora nocalora Creator

      Sure, I can mirror it to another site, like Google Drive for example.
      But that -might- take a while since my provider is extremely unstable right now.

      Did you try to download may some other file from another Mod here on ModDB? is it a problem with the site itself?

      Reply
      +
  • Damston Damston

    Hi, I have a little problem with mod. In start of the game when Yakuza appears to contact me game crashes. Could you help me with it?

    Reply
    +
    • nocalora nocalora Creator

      Sure, can you provide me with a logfile? (its in your game folder), and possibly an save-file just before the crash occurs.

      Reply
      +
  • #5Guest Guest

    Hello.

    I've just installed the mod following the advices in the readme.txt, but whatever I do, the game crashes at the start, just when the triada got shotted by Viper and her MSF minions. I don't know what could be wrong. Any ideas?

    Reply
    0 +
    • nocalora nocalora Creator

      Could you provide me with a save of your game before the crash happens, and your game's LOGfile.txt (after the crash occurs)? Thanks.

      Reply
      +
  • BlueSoleil BlueSoleil

    By the way, is there any way to disable the MS switch dialog because it messes up some of the story dialog triggers (namely the 1st Ternie mission where you get the Mastiff where the ending doesn't trigger and I get the new MS but no dialogs or new quests?

    Reply
    +
    • nocalora nocalora Creator

      Was this based on Hotfix #13-14? I remember fixing this issue sometime ago.

      If this still was on Hotfix #13-14 and not on the Hotfix #6 Release, you should pm me a save file just before you get to where the ending gets triggered, a logfile would also be neat when you get to the part where it stops.

      Reply
      +
      • BlueSoleil BlueSoleil

        Ahhh, my bad. It was on Hotfix #6. It's fine now. Went through without a hitch on #14. Thanks.

        Reply
        +
      • nocalora nocalora Creator

        No problem. Feel free at anytime to post the bugs you may find while playing :)

        Reply
        +
      • BlueSoleil BlueSoleil

        Hi again. May or may not be a bug but I wasn't noticing any random contacts ingame so I started going around the files and I noticed that the StartRandomContacts function was missing in all the activate files of every location when I compared them with nanki's old mod. I mean is that normal?

        Reply
        +
      • nocalora nocalora Creator

        They should still work because I have replaced them with an updated function called StartRandomContactsNEW which is a function inside Addons\@Fleet_Mod\Config.lua.

        It is also registered inside the mod's system autorun, so it still should be executed. But there must be something wrong with it apparently, im going to look into it.

        Reply
        +
      • BlueSoleil BlueSoleil

        Oh so the other function only works with the original exe? D_D

        Reply
        +
      • nocalora nocalora Creator

        It would work with the other one, but I thought it would be a good idea to not have every different StartRandomContacts function in each System's folder, but instead in one config file.

        Reply
        +
      • nocalora nocalora Creator

        I have managed to isolate the problem, RC4 is going up in a couple of minutes. Thanks for letting me know of this bug

        Reply
        +