The Seven Kingdoms: An Age of Petty Kings

Crusader Kings II mod |

Follow 157

Event popup spam means you are not on the latest CK2 Version! Use 2.7.1! For CK2 2.7.1. Please delete old versions before installing. Install into Documents/Paradox Interactive/Crusader Kings II/mod This build should be stable for both multiplayer and singleplayer! NOT Savegame compatible with previous versions!

The Seven Kingdoms A8b [Latest]

Related to Full Version

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account: