WIC: Modern Warfare Mod 4

World in Conflict mod |

Follow 1580

Made by Briscoe for his excellent BriscoeMod, this assault map has been converted for MW Mod compatibility, along with gameplay balancing changes. MW Mod version of 4.2 or newer is recommended for playing. Note that this map is compatible with BriscoeMod as well and will not cause any conflict, even if you have older version of the map released by Briscoe -- it will function independently of the old version as if it is a different map.

mac_SnowHill by Briscoe (MW Mod Compatible)

Related to Multiplayer Map

Only registered members can share their thoughts. So come on! Join the community today and join in the conversation.

You are not logged in, join the community or sign in with your social account: