Star Wars: The Old Republic Launch Bugs – Black Screen, Error Codes and FPS Drops

For the most part, it seems like users jumping into Star Wars: The Old Republic are joining BioWare’s brand-new MMO without too much difficulty. But a few players are seeing some troubles as they load up the game for the first time. There aren’t too many solutions just yet, but BioWare is keeping track of problems on its forums so they can be dealt with.

Black Screen of Death

Some users are complaining of an issue in which they’re stuck with a blank black screen while playing. It doesn’t seem to be a driver issue, either — some players say they have two copies in their households on two systems with the same specs, and one system will suffer from the issue while the other one skirts it. Updating drivers doesn’t seem to help the issue for the ones dealing with the black screen issue.

There doesn’t seem to be much in the way of help from BioWare on the issue just yet, but users are piling their complaints in this forum post.

FPS Drops

Here’s another one that is getting a lot of reports but hasn’t been picked up by BioWare or Electronic Arts just yet. Users are saying that they’re loading up the game and seeing some massive frame-rate slowdown on the game, especially compared to other games like World of Warcraft or The Elder Scrolls V: Skyrim. There also doesn’t seem to be much in the way of a common thread for users, either — some people are just having some FPS problems with the game. This isn’t a problem for everybody, though, but a lot of people are having trouble with the issue.

Again, BioWare hasn’t jumped on board of this one, but if you want to report the issue, a lot of people are doing so on this thread.

Error 9000

Sounds like Error 9000, a connection problem that finds players unable to connect or kicked out of SWTOR mid-session. The forum thread in which people are throwing down this trouble makes it sound like it could be a router or firewall issue. There are some possible fixes listed on the forum thread, and we’re including a few steps that might help below:

  • 1. running the launcher in compatibility mode for Windows XP Service Pack 3 / Vista service pack 2 as an administrator.
  • 2. Reset your router to fabric settings. / set your firewall settings to low.
  • 3. Open your Ports router/ firewall. The port numbers that are required are 8995, 12000-12999 and 20000-30000 (TCP).

If that doesn’t help, hit this forum thread and try some of the other solutions, or leave your own troubles and wait for a response from BioWare.

Error 7

It seems Error Code 7 is an issue with DirectX, from BioWare’s response to the issue. BioWare says that if you’re having this trouble with the game, you should post your DXDiag file in this forum thread. First off, BioWare says you should follow these steps to make sure you’re up to date:

  • You should make sure that you have the latest version of DirectX installed on your system. For further details please check here.
  • Check that your Graphics card and Sound card have the most recent drivers installed. For instructions on how to update your Graphics card please see here, for Sound cards please see here.
  • You should check that you have the latest Service Pack and Windows Updates installed for your operating system, including optional updates such as .NET Framework and Visual C++ features.
  • Check the minimum specifications of the game, to determine whether your computer may experience difficulties running the game.

After that, hit the forum and follow the steps listed to gather your DXDiag file, then post it on the forum thread.

If you’ve got other issues — or better yet, if you find some solutions to these ones — share them in the comments so other players can benefit from your wisdom.

Join the Conversation   

* required field

By submitting a comment here you grant GameFront a perpetual license to reproduce your words and name/web site in attribution. Inappropriate or irrelevant comments will be removed at an admin's discretion.

23 Comments on Star Wars: The Old Republic Launch Bugs – Black Screen, Error Codes and FPS Drops

mark

On December 21, 2011 at 1:14 am

At present is a 1000 long post on the forums about launcher problems..people are getting problems downloading the game and even if patching from the hard copy run into errors which at present is no fix.

People have been having this problem since the beta test weekends and now into launch are unable to play a game they have bought..
Fix? well still no come back from bioware at all about this bug but a 1000 post with over 64000 views must be drawing attention to this

Ryan

On December 22, 2011 at 1:19 pm

Theres plenty of people in game, the threat to not play because of an issue won’t harm the game one bit. You lose 1 player, you gain 30 more.

Brad

On December 23, 2011 at 2:48 am

Some people manage to load up the game fine but there are no servers to choose from so you are unable to play the game at all.

Markus

On December 23, 2011 at 12:23 pm

My opinion? They are purposefully creating problems on install. There aren’t enough servers to everyone.

Why i say that, I am one of the thousands that couldnt install the game. I tried to change the hardware, OS, and even tried to use another ISP inside a Lanhouse. Nothing works.

The installer takes an eternity to download almost 12 gigas, and then it says it have to “repair” and then start downloading all over again.

I sent many requests for the “customer support”, but it simply doesnt exist at all. After 48 hours, I havent received any response.

For now, many users are trying to figure out a way to have the game installed by themselves, but not a word from the company.

After so many years waiting for a Star Wars decent game, seems that Lucas Arts havent learned the lesson. I want to pay for a decent Star Wars game. But theres no decency at all at Bioware’s servers and quality…

And please fanboys, dont come to me saying that they didnt knew that they would have so many users… (so many? how many?) Specially because they knew how many licenses they placed to selling.

You cant simply sell an online game and expect that people wont connect.

It smells another Lucas Arts big failure…

Bantha fodder

On December 23, 2011 at 7:24 pm

Imho i think EA rushed release for end of year sales target,simple as :) ,all issues will be ironed out new few weeks hopefully

Todd

On December 23, 2011 at 10:23 pm

I wanted this game to succeed… but I learned my lesson with warhammer online, and I was not about to repeat it.

I also think EA rushed this release… I read one post where you could not even sit in chairs in the cantinas… trivial sure… unfinished yup that also.

I blamed Myself for Warhammer online cause all over the forums I ws told it ws my machine. I went out and dumped 400 to upgrade a perfectly decent gaming machine and Warhammer still did not work.

As I have said I have not bought Star Wars but te lack of communication concerning exactly the same issues people faced during the release of EA’s last MMORPG is enough to put me off from buying this game till these problems are resolved

Randy

On December 24, 2011 at 1:09 pm

Release was definitely rushed. Aside from the big game-breaking bugs some people are seeing, there are bugs that are simply annoyances… but there’s a lot of them. And definitely more things that need polish. While there are certainly more issues than I would like to see in a game, I am enjoying it and I know eventually this stuff will be fixed. This is the second big-name game that has been released this year that suffered from so many bugs. Skyrim is the other. I think that one has more bugs than SWTOR, but they both are buggy as hell.

Karl

On December 26, 2011 at 8:31 am

This sucks! Fearing massive bugs at launch I was going to wait before jumping on this title. BUT- all sorts of magazines and websites gave this game “10/10″ “Game of the Year!” Do bugs, poor performance and absolutely lazy Quality Assurance from the developer count in reviews? I don’t think this title was QA’d at all, and this is borderline consumer fraud.

Phil Hornshaw

On December 26, 2011 at 9:15 pm

For my part, I’ve run into very few bugs in SWTOR. Lately I’ve been getting bounced from the server for an error 9000, but even that doesn’t happen that often, and it has only started happening in the last few days. I’d be interested to hear just how widespread some of the bugs really are.

As for the QA discussion:
I definitely agree with you guys that QA has been terrible this year on lots of games, including Skyrim and SWTOR. My question to you is — do these games get any kind of grace period or leeway given how absolutely huge they are? Just wondering where your thoughts are on that.

Karl

On December 27, 2011 at 1:32 am

QA– I think a game like SWTOR deserves a little slack in the QA dept for the first couple of weeks– but Skyrim was a mess even on the XBox 360, which is a static platform they certainly should have tested on.

Peter

On December 27, 2011 at 12:24 pm

I havent had any problems until today´s patch. After a gigantic queue, i log on and guess what? Black screen of Death . I´m pretty pissed off – even the forums now have a waiting queue, like wtf. It can be a major legal issue for bioware and ea if a good number of players are incapable of taking advantage of a service these companies are obliged to pay us since subscription.

Steven

On December 27, 2011 at 2:49 pm

Well I for one will be cancelling my subscription to SWTOR after 3 days of nightmare gameplay. It works fine in the outside scenes, but lags terribly inside buildings – so much so that it took me 40 minutes to get my character out of the Jedi Temple on Tython. Should only have taken 30 seconds maximum. I have many gaming friends and every one of them will be told not to waste their money on this awful game. Black screens, crashes, serious lagging. The worst MMORG game I have ever played. Back to WOW, RIFT, and LOTRO for me.

David

On December 29, 2011 at 2:10 pm

Well i was in the Beta and was getting a remoterenderer.dll error. This happened in the last 3 weekend invites including the last stress test. I wasn’t to worried about it because i felt it would be fixed and i had been playing fine, so i did not cancel my pre-order. Got early invite Dec 13th at 6:07 am and launched the game. POW error code 7.

BioWare never fixed the remoterenderer.dll problem and now i believe it has a conflict with the system checker. This is causing machines that are well above minimum specs to fall into the error 7 club. Now we got people who have been playing fine also joining this error 7 club. BioWare has not gave any updates on the problem for over a week. This is now in my eyes the worst thing BioWare has ever done. They are happy with the million that are able to get in and are ignore the other thousand+ that are getting this error. They just don’t seem to care. EA has rubbed off of one of the last good dev teams in BioWare.

TheOddManInside

On December 30, 2011 at 3:04 am

I don’t understand how websites, TV, gamer magazines and what know can justify publishing this game as well as others as “Game of the Year”, before its even released, let alone if count the problems after. That is consumer fraud, and I have plenty of friends who like dealing with that. As for those who preferred the digital download, such as my self…wtf, 16hrs later I’m still downloading crap…28gb of material downloaded, installed and…, I have to download another 5gb of something. As for the graphics, yes photo-realism may be out of the question for now, but gee cartoon like skins? Seriously? That could be understandable maybe 5 years ago, might as well be running Direct X 8 or 9 again, no need for technology advancements.

TheOddManInside

On December 30, 2011 at 6:46 am

Still downloading…

TheOddManInside

On December 30, 2011 at 7:03 am

Wow…finished downloading, installed whatever patch or asset then had me subscribe…restart launcher…well what do you know, more stuff to download and install.

CrimsonCadillac

On January 1, 2012 at 10:21 am

Sadly all of these annoyances existed in beta. The Error Code 7 seems to be the bug a lot of users had where we received no error code the game simply crashed on launch for no reason. I spent many hours providing information to support and nothing was done. Many users diligently reported all bugs in beta, some were fixed most were ignored to make release. Current model of setting a release date for stock pricing and sales figures is really turning out some launch failures. Sadly this is a Star Wars game. Regardless of issues they new people would still pay. They released an unfinished and unpolished product that they will keep trying to fix on the back end. Beta no longer is a period to fix, it is simply the period before release where devs take feedback and mostly ignore it unless they feel it will crash the servers.

CC

David

On January 1, 2012 at 6:17 pm

@Crimson

as a member of the Beta team i have to say this. This was the WORST group of beta testers i have EVER been a part of. There was only one Beta i was in that seemed to have 90% adult gamers who constantly had input and pointed out how to recreate bugs. It was like everyone “knew” what they were doing and that was the Jump to Lightspeed beta :) that expansion came out CLEAN.

I was proud to have been a part of the best beta group in gaming history ( lol ) swtor beta it became very clear to many that 80% of the testers had no clue what they were doing and where ignoring bugs or just bypassing them to “play”. The Forums would get maybe 4 or 5 new posts and then most of the other ones were in all ready reported bugs saying “fix this NOW” instead of helping solve the problem. Beta groups and the luck of the draw ( for the company not the beta testers ) to land the best testers is a shot in the dark and can make or break a game. To many 12-16 year olds were in this beta just “playing”

mark

On January 7, 2012 at 3:00 pm

17 days on from my 1st post at the top of the page…still no fix insight for this launcher/patcher error where it just loops after attempting repairs..
4 calls to customer service…checked my logs and dxdiags and they admit theres corrupt data on servers somewhere..shame i knew that on the 21st dec

mrslavamir

On January 19, 2012 at 9:55 am

ALt + Enter… and everything works ;)
This is a solvation!!!!!!

tieslack

On January 19, 2012 at 3:07 pm

I think that this is a new game, and as is the case with ALL new games there is bugs and glitches that need to be worked out. with time, I can see this game being a very good game. provided they collerberate and don’t lose focus on the universe that they created

Jay

On March 6, 2012 at 11:44 am

I been playing and i see no problems other than minor bugs like not being able to loot something when it says you can.. I had the same issues with world of warcraft anyways so i wont get my panties up in a bunch over dumb crap..

Rex

On August 4, 2013 at 1:31 pm

Give me the solution for C5 error please.