RFAExtractor doesn't work right with 1.3!!! -1 reply

Please wait...

psychoslaphead

ET in Arcadia Ego

50 XP

4th January 2003

0 Uploads

161 Posts

0 Threads

#1 18 years ago

Tried extracting objects.rfa, and I get error messages on the sounds. Maybe one of the reasons the sounds aren't working right is the files are messed up?




Bliggup

I post to get attention

50 XP

30th December 2002

0 Uploads

64 Posts

0 Threads

#2 18 years ago

I got the same errors. I really don't know if I like this patch or not. It seems to have some other little annoying issues. I'v seen where someone said to unistall Bf1942 and start from scratch and then install the patch. Haven't tried it though. This might actually take care of some problems.




InsertNameHere

The Internet ends at GF

50 XP

18th January 2003

0 Uploads

92 Posts

0 Threads

#3 18 years ago

Yeah, a whole bunch of my sounds cut out. The random crashes lessened from a clean install, but they're still there (especially in Berlin, Tobruk, and Battleaxe). It runs smoother, but it seems like the AI is dumber. I don't really get the need for a new message system (what's the little bar to the left of messages in the Kills/Captures part?). Some of the sounds in objects didn't extract for me, either. The only main pain was having to completely re-code a good portion of my mod (which I was just finishing up after 2 weeks) for the new version. It seems like DICE tried to set up a system where adding new classes is easier, but I couldn't add one. Plus, they put a wallhack in it! Could they make any bigger mistakes? :(




psychoslaphead

ET in Arcadia Ego

50 XP

4th January 2003

0 Uploads

161 Posts

0 Threads

#4 18 years ago

Did you guys find the RTR objects hidden in the patch yet? They extract fine....

Some of the crashes may be caused by junk I've been finding in the code - they would refer to something that didn't exist or had a changed name or something.




InsertNameHere

The Internet ends at GF

50 XP

18th January 2003

0 Uploads

92 Posts

0 Threads

#5 18 years ago

I wish all of the files for the Sten would have been there, would really help my mod. Guess I ahve to go shell out yet another 20 bucks to the money-hogging bastard we know as EA...:(




PeterV

Slightly cooler than a n00b

50 XP

2nd February 2003

0 Uploads

34 Posts

0 Threads

#6 18 years ago

I had the common V1.3 sound problems, and crashes to desktop. Then I re-installed DX9 and it all runs 100% perfect now.

My V1.3 objects.rfa won't extract with RFA Extractor. Having the same errors as Psychoslaphead mentioned. You can see that it was updated, by the 16-Jan date stamp on it now. The sound.rfa they just added a sound_001.rfa, probably because the sound file is so huge. Whereas the objects.rfa is only 1 Mb approx.

That means that my game is using the new patched objects.rfa fine, and it is Mosleys extractor that has now come across something different that it can't handle. Maybe he will do an update.




InsertNameHere

The Internet ends at GF

50 XP

18th January 2003

0 Uploads

92 Posts

0 Threads

#7 18 years ago

You re-did DX9? Did you just install over it, or somehow roll back to a previous version?




psychoslaphead

ET in Arcadia Ego

50 XP

4th January 2003

0 Uploads

161 Posts

0 Threads

#8 18 years ago

I tried a complete reinstall of the game and reinstall of DX9. Sounds are still FUBAR. This is the only game I've ever had ANY kind of sound problem with (which include a lot of flight sims that do a lot more calcs than this one does), and the problem is mainly with the hardware sound implementation. 1.2 ran fine for me in software mode, but hardware mode was completely missing some sounds and others would come and go. 1.3 software mode has sounds that occasionally go missing, and the hardware sound is hollow and muffled, and crackles on louder sounds, almost like dma problems. This is with a soundblaster live, probably one of the most common cards on the planet.

DICE/EA have admitted they still have sound issues to deal with, which makes me wonder why the patch got released in the first place.




PeterV

Slightly cooler than a n00b

50 XP

2nd February 2003

0 Uploads

34 Posts

0 Threads

#9 18 years ago

Just re-run the DX9 installation and it will go 'over the top' of the old one.

BF is definitely one of the worst sound programming games around. Seemingly worse with SBlive than other sound systems.

I have three PCs, all with different on-board sound systems. All crashed after V1.3. All got better again after re-installing DX9.

But it seems that some other systems don't improve much, or at all, after DX9 re-installation. So for those systems it looks like a wait until the V1.3a (?) patch arrives, soon.




psychoslaphead

ET in Arcadia Ego

50 XP

4th January 2003

0 Uploads

161 Posts

0 Threads

#10 18 years ago

I tried re-install of DX9, did nothing. Deleted the game and reinstalled patch - more problems. I give up - I just deleted the game again and went back to 1.2 - at least it's stable.