Age of Empires III - runs way too slow, help! 4 replies

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

I have all of the right specs to run this game. Brand new HP laptop. When I start it tho, everything lags, the graphics are choppy and the responses are delayed. Any suggestions on how to fix this problem? Do i need an update, etc? I am running windows vista, unfortunately. I have disabled the Aero as well, but doesnt seem to have fixed the problem. Thanks!




Sgt. D. Pilla

Uber Geek

50 XP

23rd October 2007

0 Uploads

3,473 Posts

0 Threads

#2 10 years ago

Your graphics card isn't powerful enough, and no point in disabling Aero as Vista does it when games load so it will have no effect. Also, don't blame the issue on Vista, its not Vista, its your machine isn't powerful enough

Provide the specs of your system, if you don't know what they are, Go Start>Run>dxdiag And save a log file of dxdiag, then upload it to the post




[DD]triple

GF Pwns Me!

50 XP

25th December 2006

0 Uploads

61 Posts

0 Threads

#3 10 years ago

For any game:

Screw the stats on the box, you need more.

When AoE 3 is concerned the shaders need a 7800 or 8600 or better to run smoothly.




Sgt. D. Pilla

Uber Geek

50 XP

23rd October 2007

0 Uploads

3,473 Posts

0 Threads

#4 10 years ago

^^LIES!!! I runs smoothly on my old 6600, only SM 2.0

Maybe he should invest in a DESKTOP system, things that are designed for gaming, laptops are shitty excuses for using up the left overs




Kilobyte

What does the Fox say?

69,060 XP

23rd November 2002

0 Uploads

6,468 Posts

0 Threads

#5 10 years ago

Well, some Laptops are actually decent for gaming, especially if you follow these simple steps.

1. Make sure you get a laptop with a higher end Geforce, or Radeon card. Or make sure you can upgrade the graphics card.

2. Disable the power saving features, and only use it while its on the charger.

3. Make sure you remember to update the drivers.

4. Either run a light AV, or disable it while playing a game.