Aoe3 not working on vista -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 11 years ago

Heya, yea i recently bought a new computer with vista and installing it is fine but when i come to open it a message about protection stub not working, and it doesnt open which is very annoying.. any ideas on how to solve this cheers




Supercalifragilisticexpialidocious

I think Mary Poppins is fit.

50 XP

13th July 2006

0 Uploads

3,189 Posts

0 Threads

#2 11 years ago

Check out this news post here and that should help you.




Guest

I didn't make it!

0 XP

 
#3 11 years ago

You should try holding the ctrl button down, or temporarily shutting down your firewall.




Mikouen VIP Member

What?

145,650 XP

4th September 2005

4 Uploads

11,732 Posts

2 Threads

#4 11 years ago

No. Never disable your firewall while you're connected. Ever.

It is essentially one of the single dumbest things you can do as far as system security is concerned.


I don't know how, and I don't know why, but this is totally Sheep's fault.



Guest

I didn't make it!

0 XP

 
#5 11 years ago

yea tried doing tht , ( i mean downlaoding the new patch) but still the same message is coming up which is extremely annoying :mad:




Supercalifragilisticexpialidocious

I think Mary Poppins is fit.

50 XP

13th July 2006

0 Uploads

3,189 Posts

0 Threads

#6 11 years ago

Could you please upload a screenshot of the specific error?




Guest

I didn't make it!

0 XP

 
#7 11 years ago

yea ive done it as an attachment cheers




Supercalifragilisticexpialidocious

I think Mary Poppins is fit.

50 XP

13th July 2006

0 Uploads

3,189 Posts

0 Threads

#8 11 years ago

I did a quick search and seems someone has solved this issue.

The following should work:

(Add age3.exe into the DEP exception list) What I did is under "System" in Control Panel. Goto "System Protection". Under Adnaced Tab, click on Settings under Performance. Click on Data Execution Prevention tab and add the age3.exe into the exception list. Then click ok.

(Run the game as administrator) If you got error about writing logs in the AOE3 directory, right click on the shortcut. Under the Compatibility tab, check the "Run this program as administrator". Then click ok.

For more information, you can check this thread here

Hopes this helps.




Guest

I didn't make it!

0 XP

 
#9 11 years ago

yea thts worked, cheers for the help much appreciated




Supercalifragilisticexpialidocious

I think Mary Poppins is fit.

50 XP

13th July 2006

0 Uploads

3,189 Posts

0 Threads

#10 11 years ago

No problem. Enjoy.