Map editor BMP map preview problem.... -1 reply

Please wait...

Major A Payne

The 6th Day

50 XP

7th August 2002

0 Uploads

2,535 Posts

0 Threads

#1 8 years ago

Does anyone know the correct settings to save these BMP preview files to?? It would appear the Armada 1 map editor is screwing something up as my test map doesn't show its preview when selecting it.




Freyr VIP Member

A2Files Staff

46,875 XP

6th February 2005

11 Uploads

4,275 Posts

0 Threads

#2 8 years ago

I think it's just a (120x) 24bit bitmap in the /bzn folder with the same name as the map.




Major A Payne

The 6th Day

50 XP

7th August 2002

0 Uploads

2,535 Posts

0 Threads

#3 8 years ago

It is but it doesn't show.




Achilles

I stole fire from the lighter!

50 XP

13th January 2003

0 Uploads

1,596 Posts

0 Threads

#4 8 years ago

is it there? my editor doesn't save them so I have to take a screenshot and make it from that.




Major A Payne

The 6th Day

50 XP

7th August 2002

0 Uploads

2,535 Posts

0 Threads

#5 8 years ago

What settings do you save the preview part Achilles with as even after resizing the image still doesn't appear?




Achilles

I stole fire from the lighter!

50 XP

13th January 2003

0 Uploads

1,596 Posts

0 Threads

#6 8 years ago

Bitmap (bmp) 160x160 pixels Format : Windows Encoding : RGB Depth : 24 bit filesize : 75.0KB

That's as much as I got. I always stick to small map names and lower case letters but that's a habbit I kept from A1 so I'm not sure how relevant it is now.




Freyr VIP Member

A2Files Staff

46,875 XP

6th February 2005

11 Uploads

4,275 Posts

0 Threads

#7 8 years ago

He's using A1. :)

That said, Achilles has just jogged my memory. Back in the old days (~2003) I remember people having this problem on the gaming side and we discovered the problem was caused by using capitals, spaces or more than 8 characters in a map name.




Major A Payne

The 6th Day

50 XP

7th August 2002

0 Uploads

2,535 Posts

0 Threads

#8 8 years ago

Nope. Not the problem. My maps name is 2testmap.bzn which still conforms to the 8:3 filename of A1. I also found out that my map shows as being usable for 8 players !!??!! when I've only got 2 camera points (which are correctly named as the map is usable by me and the AI), so perhaps that might have something to do with it.

As you can all tell, I'm definately no mapper.




Achilles

I stole fire from the lighter!

50 XP

13th January 2003

0 Uploads

1,596 Posts

0 Threads

#9 8 years ago

oh yeah, that's a got of a problem. try adding a third camera, save it. then change/delete the third camera and save it... buggy program that it is. of and make sure the CTRL+R (I think) screen reads first player 3-8 as empty.

As for the bitmap issue I got nothing, I'll take a look if you like but you'd know as much as I do about such things.