star trek armada II ai? -1 reply

Please wait...

Darkblade89

Addicted to GF

50 XP

14th August 2002

0 Uploads

274 Posts

0 Threads

#1 16 years ago

I have made my own compilation of ships from various creators, and made my personal dominon race, and everythings balanced and working, but there is one bug. The ai... everytime I start a game with dominon ai, I get about 10 mins into game then it crashes, just goes back to windows..... is there a tutorial for the ai for armada 2?:mad:




Porty

Warrior Ant

50 XP

21st August 2002

0 Uploads

505 Posts

0 Threads

#2 16 years ago

It sounds like the AI is attempting to build a ship that does not exist in your game or that the name of a ship that does exist has been spelt incorrectly.

Other possibilities are that you have missed a quotation in the build list or have asked for a ship that is dependant on a particular station to be built before that station.

good luck!! :)




Darkblade89

Addicted to GF

50 XP

14th August 2002

0 Uploads

274 Posts

0 Threads

#3 16 years ago

i rechecked it like 30 times... but i will try again.. but i did not check to see if it was trying to build something that was dependant on something that was not yet built..




Porty

Warrior Ant

50 XP

21st August 2002

0 Uploads

505 Posts

0 Threads

#4 16 years ago

If it is not that, sometimes it helps to get a fresh set of eyes on it. It's easy to miss a mistake a numnber of times and when you do finally find it, you kick yourself for not seeing it sooner!! :D




Darkblade89

Addicted to GF

50 XP

14th August 2002

0 Uploads

274 Posts

0 Threads

#5 16 years ago

for instant action, what aip files do the ai use? and for multiplay? i know next to nothing when it comes to ai:lol:




Porty

Warrior Ant

50 XP

21st August 2002

0 Uploads

505 Posts

0 Threads

#6 16 years ago

I'm not completely sure myself which aip's are required but if you go and download Westworlds Big Book of Modding there is a whole section devoted to modding the AI.(Along with many other useful tutorials) :D




Darkblade89

Addicted to GF

50 XP

14th August 2002

0 Uploads

274 Posts

0 Threads

#7 16 years ago

yet another question: why do some files have 2 and some have 4, lines of numbers after the name of ship?:confused: i have westworlds book of modding, it didnt really have much to help// if i remember right, havent opened it for like a month lol




Porty

Warrior Ant

50 XP

21st August 2002

0 Uploads

505 Posts

0 Threads

#8 16 years ago

Page 117 of The Big Book of Modding tells us all about the third & fourth numbers in the AI. Suggest you open it up again :lol: !!

The AI tutorial starts on page 112 and goes through to 119 so there is a fair bit of info there, could be worth a re-read if you are still having probs.

Haven't read it myself yet, just skimmed through but will have to have a closer look before to long. :D




Warborg

Revenge was here.

50 XP

2nd August 2002

0 Uploads

1,833 Posts

0 Threads

#9 16 years ago

Another famous cause of a crash well into the game is a missing weapon file. The game doesn't have a problem until it builds the first ship that uses that weapon. Also make sure the weapon.spr file in the sprite folder is up to date. I know in my dominion mod I had to replace the weapons folder with theirs.