Very Important. 600% Perfomance Increase for Audigy 2 Owners. -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 13 years ago
Trojanman190

Dread thinks I'm a special person

50 XP

27th July 2004

0 Uploads

346 Posts

0 Threads

#2 13 years ago

Does it work for Audigy Gamer series sound cards or is it only Audigy 2?




Guest

I didn't make it!

0 XP

 
#3 13 years ago

I Believe only Audigy 2. You could try.. However, but don't get mad at me if it breaks your game and you have to reinstall. Make a back up of stuff, then try.




Trojanman190

Dread thinks I'm a special person

50 XP

27th July 2004

0 Uploads

346 Posts

0 Threads

#4 13 years ago

EH, my performance duznt suck so i wont make the risk.




OneTinSoldier

Circular Error ProbabilityZero

50 XP

24th October 2004

0 Uploads

465 Posts

0 Threads

#5 13 years ago

Nice try but no banana on my system: ---------------------------------------- [color=SeaGreen]Nice Try: [color=Black]I implemented the fix as instructed. I was like WOW, Awesome! It works as advertised!!! This is so much better and the game is indeed smooth after just 5 seconds of playing! [color=Red]No Banana: [color=Black]I had the following problem both times I played the game with this fix implemented. When the map would switch and the screen was showing the top three scorers(Gold, Silver and Bronze medals) and now I forget what else it shows, the best squads from both teams? And it has the map loading progress bar on the bottom with the BF2 theme music playing. The progress bar would get to 32% and my BF2 theme music stutter and then my system would be locked up. I tried a couple of things to get my system to reboot. First, even though I was stuck on the map loading game screen I tried... 1) CTRL+ESC --> Up Arrow --> press Enter --> Right Arrow twice --> press Enter This combination is to get your system reboot. You will see that is what it does if you try it out while you are just at your Desktop only. 2) Pressing the Power button on the front of my case in order to get it to do a soft shutdown. But to no avail, or perhaps I just didn't wait long enough because sometimes you have to wait like 5 minutes! I'm not that patient so after a couple of minutes I just turned the power to my system off(switch on the back of my case). Again, exact same problem both times I tried it. Two lock-ups on my system is enough for me to know that this doesn't work for me. [/color][/color][/color][/color]---------------------------------------- Damn I wished this worked without any issues! This would be great if it actually worked without any problem. Obviously I am going to be regressing to the original 'BF2OpenAL.dll'. Some people have said that the reason you get lag for the first minute or two of being in a newly loaded map is that the textures were still loading into your video card's memory during that time. After using this fix that is obviously not the reason for the laggy first minute! System Specs: Intel 3.4C(C = Northwood Core) on Asus P4C800-E Deluxe(Intel 875P + ICH5R Chipset), Zalman 7000a-Cu HS/Fan, Enermax RG651P-VE 550W PSU, 1 GB Mushkin High Performance(2-2-2) PC3200 RAM, NEC MultiSync FE2111SB 21" Monitor, Sapphire Radeon X800 XT PE Videocard with v5.6 Catalyst Drivers, DirectX 9.0c, Creative Audigy2 Platinum Soundcard with Driver v1.84.55, 250 GB w/8 MB Cache Western Digital HDD, WinXP Pro SP2




OneTinSoldier

Circular Error ProbabilityZero

50 XP

24th October 2004

0 Uploads

465 Posts

0 Threads

#6 13 years ago

Well I got it working properly. But, check this out... after getting it working properly I get stuttery lag for the first minute or two of gameplay on a newly loaded map! :lol: This is the main reason I like servers that play the same map for 3 rounds at a time. I think the only way I may be able to get rid of the stuttering during the first minute or two on newly loaded maps is to get some more RAM. I currently have 1 GB. I think I will be getting another 1 GB for my birthday which is in one month. If I do it should be interesting to see if that clears it up. Before I got this tweak(if you want to call it that, it requires a specific driver!) working my game ran ok. Framerate was good, very playable, but I would have some stutters now and then, and they could be pretty bad sometimes, like a stutter that lasted long enough to get me killed! With this tweak working properly now I still have some stutters but not as often nor as bad. In other words the game is running a little smoother now. No stutter/lag bad enough to where I get killed due to it. So I think it's worth it. ;) If you are an Audigy 2 or Audigy 2 ZS user and want to try this out for yourself then I will give instructions on how-to in case you aren't familiar with doing this type of thing. First, you should know that you will not be able to install certain optional components, like the Creative Speaker Settings app or the Creative Mixer, MediaSource, ect. Also note that if you have over 1 GB of RAM or do not have all your Video and Sound settings at High may not see any difference in your game's performance after doing this. My settings are all at High except Dynamic Shadows which I have set at Medium. ------------------------------------------------------ As far as I can tell... You must have the Beta driver with OpenAL Support installed or this won't work! If you are using the latest regular driver(v1.84.55) or earlier version you must completely uninstall it and then install the Beta Driver w/OpenAL Support. Again, to my knowledge you will not be able to install any optional components afterwards. Instructions: You choose to do the following procedure at your own risk! Go to www.soundblaster.com and click 'Support'. Download the Beta Driver with OpenAL Support released 05-APR-05 18.84 MB's. Now uninstall your current driver from the Control Panel... Control Panel --> Add/Remove Programs --> Soundblaster Audigy 2 Reboot. If you still have sound after rebooting then you still have a sound driver installed! You must take another step in order to completely remove it. The following should completely uninstall it... Control Panel --> System --> Hardware tab --> Device Manager --> Click the + sign by 'Sound, video and game controllers' --> Right-click 'Creative SB Audigy' --> Select/click 'Uninstall' --> You will receive a warning that you are about to remove the device from your system --> Click 'OK' When you reboot you Windows XP will re-detect your Audigy 2 Sound Card and prompt you to search the internet for a driver, choose 'Not at this time'. Then you will be prompted to search your hard drive for a driver, click the 'Cancel' button. Now you may want to go into 'C:\Program Files\Creative\SBAudigy2\Program' and delete any old stuff left in there, I did. Now install the Beta Driver w/OpenAL Support that you downloaded earlier. During the installation of the driver you may be prompted that it is trying to overwrite file(s) that already exist on your hard drive with an older version. Click 'Yes/OK' to overwrite the newer files with the older version that the Beta driver is installing. Reboot. Now follow SiLvABuLLetZ's instructions which I copy and pasted below(with some very slight modification). You don't need to go to the EA FORUM link unless you just want to have a look at that thread. But it is very important that you follow the instructions. Originally posted by SiLvABuLLetZ: I just came across an official forum from EA and the guys totally messed up the EAX thing. They figured out how to fix it with a few replacements of files, and after installation of these files, BF2 will not stutter, system lag, or freeze frame once after 5-10 seconds of each map, THATS IT. Anyone with an Audigy 2 Sound Card needs to check out the forum, or follow my easy step by step process (They explain the reasoning for the problem in the forum.) THIS FIX HAS WORKED FOR 95% of the people who tried it. -(I guess the other 5% didnt follow the steps I list below correctly) http://forum.eagames.co.uk/viewtopic.php?t=3256&postdays=0&postorder=asc -- EA FORUM Follow these easy steps below this link Carefully ***(VALUE AUDIGY 2 USERS SKIP STEP 1)***: Please make sure you have the latest Creative drivers in the first place (most importantly the beta drivers that enable OpenAL support) BEFORE You do these steps. 1. Install the OPENAL32.exe App from Creative (Link Below, it's an update to the OpenAL Beta Driver). http://developer.creative.com/articles/article.asp?cat=1&sbcat=31&top=38&aid=46&file=OpenALwEAX.exe No, it's not a virus or else you could sue Creative for mass distributing one. No, this will not ruin any sound in other games. ** A box will come up, click yes I agree.. yadda yadda yadda, and you're done.** 2. Go into your windows/system32 directory, NOT YOUR CREATIVE DIRECTORY. Copy the OpenAL32.dll and paste it into your BF2 Directory (Main Folder). DO NOT CONFUSE THE OpenAL32.dll file for the OpenGL32.dll. THAT WILL CAUSE PROBLEMS. 3. In the BF2 Main Folder, make a backup of the BF2OpenAL.dll file and put it some where that you could remember where it is if any bf2 problems occur. 4. Rename the OpenAL32.dll file you got from the System32 directory to BF2OpenAL.dll and replace the original BF2OpenAL.dll. Don't forget to make a back up of the original (just in case). 5. Play the game. I swear to you all that I creamed my pants when BF2 stopped stuttering for like the first 5-10 seconds and not the 5 - 10 minutes AS USUAL. I have a 4000+ AMD with 1 Gig of good ram, and a sweet ass motherboard. I did not deserve the stuttering, and neither do you. HAVE SO MUCH FUN. ------------------------------------------------------ Hope that helps, OneTinSoldier System Specs: Intel 3.4C(C = Northwood Core) on Asus P4C800-E Deluxe(Intel 875P + ICH5R Chipset), Zalman 7000a-Cu HS/Fan, Enermax RG651P-VE 550W PSU, 1 GB Mushkin High Performance(2-2-2) PC3200 RAM, NEC MultiSync FE2111SB 21" Monitor, Sapphire Radeon X800 XT PE Videocard with v5.6 Catalyst Drivers, DirectX 9.0c, Creative Audigy2 Platinum Soundcard with Creative OpenAL Beta Driver, 250 GB w/8 MB Cache Western Digital HDD, WinXP Pro SP2