Allocating Memory CMD-Line -1 reply

Please wait...

species652003

*Reach-Out And Touch Someone*

50 XP

17th March 2004

0 Uploads

20 Posts

0 Threads

#1 15 years ago

I don't know about anyone else here, but after I finally got FH to work on my pc, I am still having my system lock-up when trying to join FH servers that are playing certain maps (Prokhorovka, Fallweiss-1939). The only thing that I can think of that may be the cause of this, is with the size of our physical RAM + Virtual Memory sizes. (Cut from a web site) Ideally, you should make sure the sum of your physical RAM + Virtual Memory is around 1.2GB or even higher if you use memory-intensive games and applications. For example, if you have 512MB of RAM, set your Page File to 768MB Min/Max. Windows uses the swapfile to provide additional memory if your physical memory is insufficient. Having a smaller swapfile doesn't necessarily mean more use of RAM, and it often results in insufficient total memory to run most newer applications and games and hence a crash to desktop. Now this makes perfect sense! Would it be possible to create a custom shortcut allocating memory from the BF1942 Cmd-Line much like we used to in the game Half-Life icon [color=red]C:\Half-Life\hl.exe –console –zone 1024".[/color] [color=red]-heapsize XXXXX [/color][color=red]Where XXXXX is, you can place a number, and Half-Life will allocate that much memory (in kilobytes) for use with the game. While many recommend setting this anywhere from 75 to 100% of your system memory,[/color] If there was a way to do this using Forgotten Hope we could assign what is needed and go on from there :type:




NoCoolOnesLeft

My Blood Is Olive Drab

50 XP

19th November 2003

0 Uploads

4,329 Posts

0 Threads

#2 15 years ago

:confused:




BAM

I pretend I'm cooler than AzH

50 XP

27th April 2003

0 Uploads

3,415 Posts

0 Threads

#3 15 years ago
species652003I don't know about anyone else here, but after I finally got FH to work on my pc, I am still having my system lock-up when trying to join FH servers that are playing certain maps (Prokhorovka, Fallweiss-1939). The only thing that I can think of that may be the cause of this, is with the size of our physical RAM + Virtual Memory sizes. (Cut from a web site) Ideally, you should make sure the sum of your physical RAM + Virtual Memory is around 1.2GB or even higher if you use memory-intensive games and applications. For example, if you have 512MB of RAM, set your Page File to 768MB Min/Max. Windows uses the swapfile to provide additional memory if your physical memory is insufficient. Having a smaller swapfile doesn't necessarily mean more use of RAM, and it often results in insufficient total memory to run most newer applications and games and hence a crash to desktop. Now this makes perfect sense! Would it be possible to create a custom shortcut allocating memory from the BF1942 Cmd-Line much like we used to in the game Half-Life icon [color=red]C:\Half-Life\hl.exe –console –zone 1024".[/color] [color=red]-heapsize XXXXX [/color][color=red]Where XXXXX is, you can place a number, and Half-Life will allocate that much memory (in kilobytes) for use with the game. While many recommend setting this anywhere from 75 to 100% of your system memory,[/color] If there was a way to do this using Forgotten Hope we could assign what is needed and go on from there :type:

i am not sure if this would work ..




Ohioan

Not Wise Shitashi - Cheston

50 XP

6th October 2003

0 Uploads

3,604 Posts

0 Threads

#4 15 years ago

First off, don't allocate 100% of your system memory. Windows will bluescreen and die because you used the memory spaces where you were storing your OS and drivers.

Secondly, the Heapsize command is a relic from Windows95 days where Windows wouldn't automatically adjust the amount of memory in some cases. Now, with modern machines, the Windows 2000/XP systems have very decent memory management and it's not needed.

Everyone crashes on Prokhorovka occasionally. It's a bug with the game, not with your memory. Don't screw around with the settings unless you have failed every other option availible to you.

The heapsize tag is a coding language device that means "return this much memory". I have no clue if it will work with bf1942 but I wouldn't reccomend it.




[SYN] hydraSlav

SYNERGY Member

50 XP

2nd October 2003

0 Uploads

2,372 Posts

0 Threads

#5 15 years ago

Why do you want to mess with heapsize? I remember the days when i used to manually unload mouse drivers in DOS in order to get more memory for some game. It's not done this way anymore. As a matter of fact, lastest versions of Windows won't let you manually assign memory space. Each instance of a program gets a max of 4GB (for WindowsNT) virtual space that is isolated from other programs and the system itself. You can however change your virtual memory settings. Firstly, to increase performance, make it a static size, not dynamic. Set the file size to something like 512MB or 1024MB, although it's recommended you set the virtual memory size to twice the amount of RAM you have




species652003

*Reach-Out And Touch Someone*

50 XP

17th March 2004

0 Uploads

20 Posts

0 Threads

#6 15 years ago

Hmmm, I appreciate it, being a win98 whor3 for 13yrs one tends to treat everything from MS as just a part of a Complete OS. Well, XP seems to be running fine. No, not to that point yet, but if I do, I am just going to use it as an excuse to format my entire HD. Anyone use Cacheman ? Not sure, but that could be contributing to my puters hemmorhoid symptoms I dunno! Thanks 4 the feed-back!

'[CNIOhioan'] Secondly, the Heapsize command is a relic from Windows95 days where Windows wouldn't automatically adjust the amount of memory in some cases. Now, with modern machines, the Windows 2000/XP systems have very decent memory management and it's not needed. Everyone crashes on Prokhorovka occasionally. It's a bug with the game, not with your memory. Don't screw around with the settings unless you have failed every other option availible to you.



BAM

I pretend I'm cooler than AzH

50 XP

27th April 2003

0 Uploads

3,415 Posts

0 Threads

#7 15 years ago
species652003Hmmm, I appreciate it, being a win98 whor3 for 13yrs one tends to treat everything from MS as just a part of a Complete OS. Well, XP seems to be running fine. No, not to that point yet, but if I do, I am just going to use it as an excuse to format my entire HD. Anyone use Cacheman ? Not sure, but that could be contributing to my puters hemmorhoid symptoms I dunno! Thanks 4 the feed-back!

hahah thats a funny sig you got :D




species652003

*Reach-Out And Touch Someone*

50 XP

17th March 2004

0 Uploads

20 Posts

0 Threads

#8 15 years ago

I was under the impression that the bug related to the maps that don't load are contributed to memory issues like, Not loading, Trying to switch from a rifle to a grenade and the damn rifle won't go away, When I am suddenly confronted by an enemy when I drop to go "Prone" upon releasing the "Prone Button" you stand back up as if I hit the "Crouch key" instead resulting in me standing back up, "Yelling here I am over here!" I was just thinking that since certain maps require more resources than other maps do it would be nice to Allocate/set aside a fixed amount of memory via each mods Cmd-Line since each mod reacts differently due to it's enviorment.

'[SYN hydraSlav'] You can however change your virtual memory settings. Firstly, to increase performance, make it a static size, not dynamic. Set the file size to something like 512MB or 1024MB, although it's recommended you set the virtual memory size to twice the amount of RAM you have



species652003

*Reach-Out And Touch Someone*

50 XP

17th March 2004

0 Uploads

20 Posts

0 Threads

#9 15 years ago

Thanks.. :bows:

BAMmeuhahah thats a funny sig you got :D