... -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 12 years ago

I need some help. Every time I click on Multiplayer, and Internet, there are a bunch of games to select. Or servers. Whatever. When I click on one of them, at the loading screen, it always says 'Wrong Version! Update Now?'. When I click on yes, it takes me to an expired page. Also, when I download Multiplayer patches, and install them after extracting. Upon clicking on the installer, while it loads, it than shows a window saying 'Setup Couldn't find a Battlefield 1942 Multiplayer Demo installation? I don't get it, what do I do? What file do I download?




testicle with legs

PROUD CAMPER SINCE 1995

50 XP

7th April 2004

0 Uploads

254 Posts

0 Threads

#2 12 years ago

all i can say is make sure that you are downloading the right patches. try bf2files.com for all battlefield related stuff.




Dark Saint

How many dogs are Pb'd?Maybe 2

50 XP

30th April 2004

0 Uploads

8,040 Posts

0 Threads

#3 12 years ago

Are you playing the demo or the full version ?




Kaneiac

I'm too cool to Post

50 XP

13th May 2006

0 Uploads

10 Posts

0 Threads

#4 12 years ago

You need Multiplayer Demo Patch 1.1 if you are playing the demo.

Depending on your version of Battlefield, you may need the 1.6 and 1.61b patches if you have the full game.

You can get either of those at the EA games website. The demo may be hard to find, in case of that, just do a google search. If you have any questions, feel free to ask, we don't bite.




TheOlive

I'm too cool to Post

50 XP

29th May 2006

0 Uploads

14 Posts

0 Threads

#5 12 years ago

Yes, You might need patchs 1.45 to 1.5 1.5 to 1.6 1.6 to 1.61 (INCREMENTAL) Depending on the game version, sometimes doesnt require for you to download 1.45 to 1.5.