BF2 ATI Radeon Issues -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 13 years ago

I have an ATI Radeon 9200 128mb running NGO's tweaked Catalyst 5.6 Drivers. My system is WinXP SP2 32bit, 1.5GB RAM, 3.4Ghz HT Intel Proccessor. The game loads, and right after the chick says "Welcome to duty" the game locks up on the black screen and crashes my computer. I tried reverting to the official ATI 5.6 drivers, but to no avail. I also tried to override DX9.0c's refesh rate to a value of 100, and still cant get the game to work. Any suggestions you can offer would be greatly appreciated.




carpanther

Overweight Soldier

50 XP

20th May 2003

0 Uploads

1,129 Posts

0 Threads

#2 13 years ago

Have you tried reverting to the old drivers? I had a similar problem with my 9500 pro, and it hasent crashed since I went back. try it out.




SteelSabre

Skeptix

50 XP

27th May 2005

0 Uploads

478 Posts

0 Threads

#3 13 years ago

9200's arent supported for Bf2




Raptor25

You're in my Crosshairs...

50 XP

7th July 2003

0 Uploads

161 Posts

0 Threads

#4 13 years ago

Nvidia's 5200 wasn't supported either but it works... :uhoh:




Fletcher

I'm too cool to Post

50 XP

11th June 2005

0 Uploads

11 Posts

0 Threads

#5 13 years ago

Try setting your agp setting to 4x. Right click on desktop Go to settings Click advances Click SMAERTGART Drag slider and click apply This worked for me in the demo. I was running standard 5.6 drivers. I don't have the full version so I can't test it.




Guest

I didn't make it!

0 XP

 
#6 13 years ago

Problem solved, thanks guys.