Battlefield 2 very strange problem...please help! -1 reply

Please wait...

Bubbleteatroopa

I got them crazies.

50 XP

31st December 2008

0 Uploads

821 Posts

0 Threads

#1 9 years ago

Hey guys, I just bought battlefield 2 delux edition, which includes Battlefield 2 Special Forces. I got everything up to date, manually uptated Punk Buster, have a system that is suppose to be able to play it on high settings, and have a descent internet connection, which works great with ANY other online game, higher graphics quality, or lower graphics quality. So heres the problem: When I start battlefield 2 Special forces, it loads fine, I log in, choose my server, and everything loads fine. The first game is great! No matter the players or the settings, I never lag, and my fps is always above 50. BUT When I decide to change servers, and play a different one, I load the map, and I get UBER LAG! Like, im not talking those first 10 seconds of a game which seems to be a bit slow sometimes, im talking UBER! The game like freezes, and I wait 10 seconds, I manage to click the spawn button (in this time, my fps is regular, about 70) and then as soon as I spawn my fps dropps to 0! And all I hear is the sound's repeating over and over again. It will eventually clear, but as soon as I get near an enemy, the game will freeze up again, and when it comes back, il be dead. Same thing happens whenever I fire my weapons, the game freezes and then 10 seconds later it goes back to normal. The same thing happens to me on ocasion with battlefield 2, and I dont have a clue why. This does not happen with any other game, and I can play 2142 perfectly fine, without any lag, or low FPS. Please, can someone help me? Its getting rely annoying.

Oh and one more thing: I get this error sometimes on battlefield 2, not usualy special forces saying something like: Player (player name) was kicked for (0) seconds. Restriction communication error: Pnk Buster B.exe.

I think this might have something to do with my problem. Punk buster makes the game choppy, and then smooth, choppy, and then smooth, etc....

So, can somebody please help me?

System Specs:

OS: Windows Vista Home Premium (yes I run as admin) CPU:Intel Core 2 Duo RAM: 2048mb DDR2 Graphics Card: NVidia GeForce 8600m GT 256mb (its for a laptop...that might be problem) Manufacturer: Acer Model: Aspire 5920g System Type: 32 bit

Internet: 54mbps, LAN connection, I dont use Wireless, cause too much interference where I live.

PLEASE HELP!:(




GateCrusher420 VIP Member

What is this place?

71,255 XP

17th February 2007

0 Uploads

6,233 Posts

1 Threads

#2 9 years ago

Uninstall the game, uninstall punk buster, reinstall BF2 & BF2:SF, repatch it, leave punkbuster alone, and try again.




Guest

I didn't make it!

0 XP

 
#3 9 years ago

i just installed 1.41. i log on and select my username but when its trying to connect to the game the game just shuts down. it shuts down after ive selected my user and pressed login. can someone help me??




GateCrusher420 VIP Member

What is this place?

71,255 XP

17th February 2007

0 Uploads

6,233 Posts

1 Threads

#4 9 years ago
GateCrusher420;4961706Uninstall the game, uninstall punk buster, reinstall BF2 & BF2:SF, repatch it, leave punkbuster alone, and try again.

Minus the uninstall of punkbuster and Special Forces if you don't have it.