BattleRacer 1.21 work with BF2 1.41? -1 reply

Please wait...

Captain Blade

custom user title

50 XP

16th July 2006

0 Uploads

1,403 Posts

0 Threads

#1 12 years ago

The latest version of BattleRacer mod is 1.21, which came out Oct. 3rd.

I'm wondering if v1.21 of BattleRacer will work with BF2 v1.41 without having any bugs or graphic glitches or any other problems?