BF2 loadup problems AFTER install of ANY patch -1 reply

Please wait...

gibroz

I'm too cool to Post

50 XP

2nd January 2004

0 Uploads

5 Posts

0 Threads

#1 12 years ago

A buddy of mine has serious issues w/ getting his BF2 to work. Recently it was working but he decided to uninstall and reinstall...now he can't play at all! Vanilla or SF. When uninstalling the game he has deleted the registry files to ensure it is completeyly removed from his hardrive. Then procedes to install Vanilla & SF, then attempts to install the patches. Patches is where the problem starts. The game works fine after initial install. He can play single player w/o issues. However, after installing the patch(s), when he tries to get onto ANY game (singleplayer or Multi) his game crashes onto the desktop during the loadup screen (consistently 'round the time "loading geometries" pops up). He says if shows "loading textures" it usually means he's going to successfully load up. He has tried the incremental patches, full patches all from different sources. Even the ones he has used in the past w/o issues. Anyone have any suggestions on how to get his game working? He has spent the last 48 hrs uninstalling reinstallling, etc. I'm suprised he hasn't given up yet. Thank you in advance for your help! Jigglin The following are his specs he gave me:(lemme know if there is any other pertinent info that may be helpful) ------------------ System Information ------------------ Time of this report: 7/3/2006, 15:05:20 Machine name: MARC_1 Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.050301-1519) Language: English (Regional Setting: English) System Manufacturer: eMachines System Model: Product Name BIOS: Phoenix - AwardBIOS v6.00PG Processor: AMD Athlon(tm) XP 3200+, MMX, 3DNow, ~2.2GHz Memory: 1024MB RAM Page File: 189MB used, 3739MB available Windows Dir: C:\WINDOWS DirectX Version: DirectX 9.0c (4.09.0000.0904) DX Setup Parameters: Not found DxDiag Version: 5.03.2600.2180 32bit Unicode --------------- Display Devices --------------- Card name: NVIDIA GeForce 6200 Manufacturer: NVIDIA Chip type: GeForce 6200 DAC type: Integrated RAMDAC Device Key: Enum\PCI\VEN_10DE&DEV_0221&SUBSYS_00000000&REV_A1 Display Memory: 256.0 MB Current Mode: 1024 x 768 (32 bit) (75Hz) Monitor: Default Monitor Monitor Max Res: Driver Name: nv4_disp.dll Driver Version: 6.14.0010.7801 (English) DDI Version: 9 (or higher) Driver Attributes: Final Retail Driver Date/Size: 8/2/2005 16:35:00, 3908864 bytes WHQL Logo'd: Yes WHQL Date Stamp: n/a VDD: n/a Mini VDD: nv4_mini.sys Mini VDD Date: 8/2/2005 16:35:00, 3198560 bytes Device Identifier: {D7B71E3E-4161-11CF-C97D-0A2000C2CB35} Vendor ID: 0x10DE Device ID: 0x0221 SubSys ID: 0x00000000 Revision ID: 0x00A1 Revision ID: 0x00A1 Video Accel: ModeMPEG2_A ModeMPEG2_B ModeMPEG2_C ModeMPEG2_D ModeWMV9_B ModeWMV9_A Deinterlace Caps: {212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch {212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch {212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch {212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch Registry: OK DDraw Status: Enabled D3D Status: Enabled AGP Status: Enabled DDraw Test Result: Not run D3D7 Test Result: Not run D3D8 Test Result: Not run D3D9 Test Result: Not run




Dark Saint

How many dogs are Pb'd?Maybe 2

50 XP

30th April 2004

0 Uploads

8,040 Posts

0 Threads

#2 12 years ago

You only need to load the latest patch ... You don't need any of the earlier patches. So if he is loading more than one, that could be the problem.




lonewoolve

I don't spend enough time here

50 XP

2nd July 2006

0 Uploads

23 Posts

0 Threads

#3 12 years ago

Hi,mabe try assigning more virtuall mem on the page file as well,and certainly all the different patches wouldnt help,so would try correcting the patching issue[means obviously deleting all Game info ,reg entries as well [only do if you know what to do],im sure there is a page on here [forum] that explains the reg stuff step by step.Check that out first,then try assigning 380 Virtual memory or until it runs ok. Looks like 189 at the moment.....i think thats too little.




Aliblista(UK)

Wayne brady bitches!

50 XP

18th March 2005

0 Uploads

499 Posts

0 Threads

#4 12 years ago

Yep, bf2 really needs a comp of around 2gb RAM to work well. Since your friend only has 1gb (like me) he really should increase his pagefile to 1gb (min and max) this should stop all errors especially as bf2 relies on the user having a large pagefile despite RAM size




gibroz

I'm too cool to Post

50 XP

2nd January 2004

0 Uploads

5 Posts

0 Threads

#5 12 years ago

Thanks guys... I'll pass the info onto him regarding the virtual memory. Can someone explain HOW to increase the pagefile please?

I'll get him to reread the registry stuff. I'm pretty sure he has done that though (registry) .Can anyone provide me w/ a link to the detailed instructions just in case? He HAS tried just the 1.3 full patch already; still to no avail. I was hoping that suggestion would fix the "patch" issues. I'll update the results if any...thanks again for the help. Jigglin




lonewoolve

I don't spend enough time here

50 XP

2nd July 2006

0 Uploads

23 Posts

0 Threads

#6 12 years ago

Emm, for virtual mem adjustment you go to,Control panel/System/Advanced/and on the Advanced page chose Perfomance/ SETTINGS.Then click on advanced tab, [making sure that the Programme/Memory usage is set to Progammes/not Background tasks, "usually is by Default" then click on the Virtual mem button that says Change.Chose Custom if Xp has assigned any less than 360 or so.Also check to see what windows has assigned automatic for you,like mine has chose around 1500,so ive not bothered changing it as i can play pretty much glitch free,although i have other unrelated probs[Connection Server].




lonewoolve

I don't spend enough time here

50 XP

2nd July 2006

0 Uploads

23 Posts

0 Threads

#7 12 years ago

448.725 Meg in a zip file is the correct 1.3 Patch file.Sorry dont have link to Reg edit post,although im Definate it was on this very page of probs and some one explains step by step how to edit it..I would still check all memory related thing before looking at the patch issue and leave the most recent clean install /Full 1.3 with no addon packs untill it starts running right.




gibroz

I'm too cool to Post

50 XP

2nd January 2004

0 Uploads

5 Posts

0 Threads

#8 12 years ago

Here's the solution figured out by one of the techs at EA... He told my friend to delete the "mods" folder in his BF2 file after installing the game. He then installed the full 1.3 patch in safe mode; (maybe the game itself too) It took a LOT longer. Patching the game regularly (i.e-NOT in safe mode) didn't work until he did the above;safe mode. Voila, now his game is working w/o issues...thanks for the suggestions though folks...maybe this will help someone else in the future w/ BF2 install woes. :rock: :cheers: BTW-He did try to increase the page file as suggested; without success. (This was b4 he was contacted by EA)




lonewoolve

I don't spend enough time here

50 XP

2nd July 2006

0 Uploads

23 Posts

0 Threads

#9 12 years ago

Wow....thats mad,lol,ive never heard ever of installing in safemode,im sure in safemode when you shut down i does not save anything you do,i mean it would install the game but any temp files or so wouldnt save,but im noooooo expert so if it worked then kool man,glad you got running man.




super6-4

GF is my bext friend *hugs GF*

50 XP

26th July 2004

0 Uploads

960 Posts

0 Threads

#10 12 years ago

i just wouldnt get the patch i hear its got alot of probs and makes alot of peps crash and makes there game not work