Catalyst 5.8 drivers -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 12 years ago

Ok i installed 5.8 drivers for Radeon 9600 Pro with 256 mb of ram and everytime i load a map to 14 percent i crash i even tried settings on low and everything please help.




Lt.vendetta

I don't spend enough time here

50 XP

29th September 2005

0 Uploads

28 Posts

0 Threads

#2 12 years ago

Did you Uninstall the old drivers first ? You have to do that before you install the new drivers, Also the drivers have been updated they now have 5.9 drivers, What ATI card are you using ?




colonel_bob

Here & There

50 XP

4th June 2004

0 Uploads

6,685 Posts

0 Threads

#3 12 years ago

They have 5.9 now? Why are these things coming out so quick? Thats not supposed to happen!




arrowhead927

battlefield veteran

50 XP

27th August 2005

0 Uploads

131 Posts

0 Threads

#4 12 years ago

do you really need catalyst 5.9




rakesh27

I don't spend enough time here

50 XP

2nd February 2004

0 Uploads

29 Posts

0 Threads

#5 12 years ago

Dude, Why dont you use catalyst v5.6, its perfect, i havent bothered with the ones above this one seems to runn everything perfectly. You might need to turn down your settings to medium and also make sure you dont have any useless stuff running in your taskbar. Also remember before installing a new driver uninstall the old one using a program called driver cleaner pro (remember to get the updates as well). Good luck hopefully the game should work.




apocalypse_kid

I would die without GF

50 XP

20th May 2002

0 Uploads

5,498 Posts

0 Threads

#6 12 years ago

There is also a tool on ATI's website to assist you in removing old catalyst versions. You don't HAVE to have the latest drivers, just make sure you have the ones that were released with BF2 onthe CD/DVD and you shoud be ok.

AK

:smokin:




maximum-p

I EAT LEET

50 XP

30th June 2005

0 Uploads

198 Posts

0 Threads

#7 12 years ago

well i had a 9600pro piece of ***t kept overheating so maby its that but i doubt it and i had some trouble wif da 5.9 on bf2 so i say stick wif da 5.6 like that guy said




Banzai_Joe

Slightly cooler than a n00b

50 XP

1st July 2003

0 Uploads

32 Posts

0 Threads

#8 12 years ago

I haven't really had any probs with 5.8 on my rad 9800pro 128mb. I was thinking of updating to 5.9 to see what its like.