Patch order for NOOB gamer -1 reply

Please wait...

grego34

I love tank games & HOOTERS(.)

50 XP

1st January 2004

0 Uploads

25 Posts

0 Threads

#1 12 years ago

what is the patch order for BF2??:confused: also should i use the client or the server?:confused: i might want to host games form my PC. I have seen so many patches for BF2 in Xfire and File shack.. Which one actually downloads in your game?? :confused: CODUO was never this hard :uhoh:




*WGO*Champ

-Play Your World-

50 XP

17th September 2006

0 Uploads

47 Posts

0 Threads

#2 12 years ago

that's easy:

-already installed patch 1.3? install this one: http://files.filefront.com/Battlefield+2+v13+to+v14+Patch/;5472230;;/fileinfo.html

-didn't install a patch yet? use this one: http://games.internode.on.net/filelist.php?filedetails=3231

that's just for playing your game, there's also a server patch file, but I don't think you need that one




SciComHam

Now with more red

50 XP

28th November 2004

0 Uploads

935 Posts

0 Threads

#3 12 years ago
grego34

I love tank games & HOOTERS(.)

50 XP

1st January 2004

0 Uploads

25 Posts

0 Threads

#4 12 years ago

i havn't installed any patches yet, I still have to reinstall the game.. So the 1.4 patch is all i need?? i always thought like in spearhead, that there was a order for the patches to be put in?? Do i need a server patch in case i like to host from my Pc??




Andro Pheonix

WE LOVE YOU LIVERPOOL!!!

50 XP

23rd August 2006

0 Uploads

42 Posts

0 Threads

#5 12 years ago

1.4 is a big download it took 6 hours but I have a shit computer but I think you need to download 1.3 aswell




*WGO*Champ

-Play Your World-

50 XP

17th September 2006

0 Uploads

47 Posts

0 Threads

#6 12 years ago

You don't need 1.3, just install this patch:

*WGO*Champ -didn't install a patch yet? use this one: http://games.internode.on.net/filelist.php?filedetails=3231



Dark Saint

How many dogs are Pb'd?Maybe 2

50 XP

30th April 2004

0 Uploads

8,040 Posts

0 Threads

#7 12 years ago

ok... for those who do not read EVERYONE elses posts.

All you need is the 1.4 FULL patch ... Do not get the incremental. No you do not need a server patch if you want to host ....