COD-UO ATI Catalyst Problem. -1 reply

Please wait...

jrcallan

Slightly cooler than a n00b

50 XP

29th May 2005

0 Uploads

33 Posts

0 Threads

#1 13 years ago

I have an odd problem with COD-UO, both singleplayer and multiplayer, if I run the ATI Catalyst drivers after v.5.2, using a Radeon X700 Pro. When I start up COD-UO, the brightness is WAY down, and I have to manually reset it in the graphics options, then it runs fine, but what a pain. V.5.2 and earlier run great, but I'd like to be able to upgrade eventually. My system is: Abit AA8 Duramax MB LGA 775 P4 Prescott CPU 3.2 gHz (not overclocked) 2 gigs of DDR2 ram Abit Radeon X700 Pro w/128 megs onboards ANybody else have this problem?




highroyds

People say I post too much

50 XP

22nd January 2004

0 Uploads

1,465 Posts

0 Threads

#2 13 years ago

Is it when your minimizing CoD / UO ?? If so its a known problem. All I do is bind 2 keys bind F9 set r_gamma 1.5 bind F10 set r_gamma 1.4 then when I minimize the game then go back I press F10 then F9 or vise-versa and the screen brightens. Havent tested in Single player but I do know it works in UO's Multiplayer.




Tally

COD Über Support

50 XP

20th November 2004

0 Uploads

3,439 Posts

0 Threads

#3 13 years ago

With ATi crads they default to having something called 'overbrightbits' on. This is why it keeps going dark. Drop down console and type: /r_overbrightbits 0 You'll get a message that this setting will take effect next time you start COD. You wont have anymore problems with brightness. :D




jrcallan

Slightly cooler than a n00b

50 XP

29th May 2005

0 Uploads

33 Posts

0 Threads

#4 13 years ago

Thanks, but it is all full screen. I've never tried to minimize COD or CODUO. Please see the other reply about ATI cards and the overbright feature. I'll try that.




jrcallan

Slightly cooler than a n00b

50 XP

29th May 2005

0 Uploads

33 Posts

0 Threads

#5 13 years ago

Thanks, I'll try that. Do you know if it's related to a cahngeable setting in Catalyst Control Center?




highroyds

People say I post too much

50 XP

22nd January 2004

0 Uploads

1,465 Posts

0 Threads

#6 13 years ago

I've been using ATI graphics cards for a while now and I know about when the screen goes dark, most of the time its when you come out of the game by pressing the Windows key to reply to a messsage or when MSN comes up with a pop-up to say when someones come online or when you have an email program running and lets you know when you've got an email. I would suggest turning all your background applications off and only have CoD or UO running then go to the options - graphics in the game and turn the brightness up a touch, then quit the game and try load up again. You should see that the games kept your settings and should stay bright. I have tried the overbightbits a few times and far as I can tell it only works now and again plus only works on certain drivers.




jrcallan

Slightly cooler than a n00b

50 XP

29th May 2005

0 Uploads

33 Posts

0 Threads

#7 13 years ago

Well it worked for me.

However, since I could not get the pulldown menu in the singelplayer version, I went into the uoconfig.cfg and uoconfig_mp.cfg files in the /UO directory and edited them both to make the "overbrightbits" value 0. Works great on repeated restarts. Thanks! Too bad one must do the editing at all. I'm really perplexed that the problem didn't show up with Catalyst v.5.2 -- only 5.4 and 5.5. Is the "overbrightbits" a recent feature for ATI?

Seems like they would want to know about it, too.

Thanks again.




Tally

COD Über Support

50 XP

20th November 2004

0 Uploads

3,439 Posts

0 Threads

#8 13 years ago

No overbrightbits has been a feature of ATi cards for ages. It does serve a purpose however, as it stops random gamma correction to creep into the game. ATi are aware of the problem with Open GL games.