How to get 'new' custom maps to work on a server? -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 12 years ago

[COLOR=black]Hello, this post is for all the server owners out there that have been able to run the ‘new’ custom maps on their servers with no problems. “Newvillers” and “Silotown” run no problem, but “Hill400” just doesn’t work, it brings up this error “CL_ParseGamestate: Bad command byte”, or something like this:[/COLOR] [COLOR=black]^3WARNING: Could not load weapon file 'weapons/mp/m1garand' ^3WARNING: Could not load weapon file 'weapons/mp/colt' ^3WARNING: Could not load weapon file 'weapons/mp/BAR' ^3WARNING: Could not load weapon file 'weapons/mp/m1carbine' ^3WARNING: Could not load weapon file 'weapons/mp/fraggrenade' ^3WARNING: Could not load weapon file 'weapons/mp/g43_sniper' ^3WARNING: Could not load weapon file 'weapons/mp/kar98k_sniper' ^3WARNING: Could not load weapon file 'weapons/mp/panzerschreck' ^3WARNING: Could not load weapon file 'weapons/mp/smoke_grenade_american' [/COLOR]

[COLOR=black]The server uses the ‘powerserver’ mod, and the max player is set to 15. What could the problem be? When I try to join other servers running ‘hill400’ half the time there is no problem, but the other half I also get “CL_ParseGamestate: Bad command byte”, even though there are players on the server who have managed to join. Could it be that there are 2 versions of the same file, one with errors and one without? [/COLOR]

[COLOR=black]We also tried ‘Tankhunt’ and it did’nt work, but someone told me that that map also crashes the server every time. Yet I also see some servers running it with no problems.[/COLOR]

[COLOR=black](If you need more information I will be happy to supply it, it’s not me who runs the server, its another person, they just don’t speak English very well, so I’m posting for them :) )[/COLOR]

[COLOR=black]So what can we do to get them to run? We are grateful for any help.[/COLOR]




maester

TeamFX Webmaster

50 XP

20th October 2004

0 Uploads

85 Posts

0 Threads

#2 12 years ago

I also have this issue with micewars_v3 it mysteriously crashes my server im running platinum mod and cortex control panel




Tally

COD Über Support

50 XP

20th November 2004

0 Uploads

3,439 Posts

0 Threads

#3 12 years ago

try running Hill400 without any mods

The error is a gamestate error. There is only 16k of gamestate in COD2. Hill400 is pushing it at 15k. Adding a mod will also chew up gamestate.




Romeo

Cogito Ergo Sum

50 XP

3rd May 2003

0 Uploads

262 Posts

0 Threads

#4 12 years ago

correct me if i'm wrong but isnt the map trying to load single-player weapons? like theres no /m1garand in mp folder only m1garand_mp




Tally

COD Über Support

50 XP

20th November 2004

0 Uploads

3,439 Posts

0 Threads

#5 12 years ago

those are deleted sp entities, and leave a 'footprint' in the compiled map. Normally such errors will not cause the server to crash or the map not to load. but in this case, the errors aren't causing the problem. the 'cl_parseGamestate error is caused by there not being enough gamestate memory to give to the client.




Magnet

Slightly cooler than a n00b

50 XP

3rd February 2006

0 Uploads

39 Posts

0 Threads

#6 12 years ago

i guess we'll have to abandon hill400, but other maps work fine, so i guess we'll have some fun on other maps. Thanks for the help!