Crysis SP Demo Release Date -1 reply

Please wait...

Stark98

I would die without GF

138,935 XP

25th March 2005

0 Uploads

13,416 Posts

0 Threads

#31 11 years ago

eum update my sound drivers, this is something else then just go to nvidia. Where can i see my sound drivers? How do i know the brand etc? any help guys.




343guiltymc

Revenge was here.

50 XP

20th February 2006

0 Uploads

1,662 Posts

0 Threads

#32 11 years ago
Sovereign001;4006576eum update my sound drivers, this is something else then just go to nvidia. Where can i see my sound drivers? How do i know the brand etc? any help guys.

Just go to control panel and find your sound card. Then just click update drivers.




Brusher

The forums staffers think I'm Cool

50 XP

20th April 2007

0 Uploads

155 Posts

0 Threads

#33 11 years ago

Finally! I got Crysis 64 working in Vista. Had to uninstall Nvidias "Network Access Manager" from the Windows Vista control panel.

Before this, I had tried, as suggested, the newer drivers 169.01 and 04, and I even tried the older, previous drivers with no luck. With all of them in 64 bit, I always got a black screen from the very start and then nothing happened. But all it took was what I said above. Remove that and that should do it if anyone has the same problem.

Works fine now except for the 23 fps average on very high settings. But at least it works now which is way more than I could say before.




>Omen<

Modern Warfare

50 XP

1st January 2005

0 Uploads

7,395 Posts

0 Threads

#34 11 years ago

Hmm, interesting, I'll pass it on in case anyone else has the same problem. Maybe you could stop by at the EA Crysis forum where many players are complaining of various problems. I get the feeling from what you said you were either playing online or left your net connection enabled while playing sp. I've been using FSAutostart for some time now which automatically stops and restarts all background programs and non essential services, leaving me uninterrupted as it also disables anything using the net. It also forces idle tasks (like system restore) and defrags the RAM before launching the game. FSAutostart used to be bundled with MS Flight Sim 10 and is now a free standalone program.




Brusher

The forums staffers think I'm Cool

50 XP

20th April 2007

0 Uploads

155 Posts

0 Threads

#35 11 years ago

Yeah, at first I discovered that if I disabled my DHCP Client in system services that the demo worked fine. But then, of course, my internet wouldn't work. Since I did have the online beta version installed I knew it must have had something to do with that. That's when I uninstalled the network access manager and then re-enabled my DHCP Client. Now internet, and demo, work fine. Crysis online, I don't know. Haven't tried that again yet. Probably have to reinstall the NAM. I don't know how to disable my online net connection after playing online. Didn't know I had to so I didn't look. I'll check that out if it ever becomes a prob again.

Thanks for the tip on the FSAutostart. I'm glad to know about it. I used to use a program called EndItAll but that was when I used to play air warrior online with win 98. They haven't been updating and supporting it since then so it doesn't work very good with XP or Vista. I will definately give FSAutostart a try.




Guest

I didn't make it!

0 XP

 
#36 11 years ago

Damn, didn't come here in a while :P "There have been 1,303,307 posts and 92,022 threads since your last visit at 01:08 PM, February 28th, 2006."

Well anyway, I installed the demo and it works pretty well for me, the game is fantastic, it feels a bit like PREDATOR. I just love throwing a barrel on 3 korean soldiers and be able to literally destroy, kill and pick-up almost anything. Didn't know you could kill flying birds and pick-up living chicken or crabs and throw then away, that's damn funny. The graphics are pretty freaking impressive too, the in-game cinematics are just surreal. I'm almost certain I'll buy the game, along with maybe SOF:Payback which I'm looking forward to play.

Outside, I have between 30-45 FPS on all high except shadows which I put at low (they eat like 5-10 fps). at 1680x1050. I expected way much worse.

Specs are: Windows XP 8800 GTS 2 gigs of ram e6400 @ 2.4 gHz




Guest

I didn't make it!

0 XP

 
#37 11 years ago

thats actuall a pretty good system for crysis. i cant play it till thurs, mabe wed. still waiting on that videocard.




N88TR

Old school pimp

50 XP

10th February 2004

0 Uploads

9,921 Posts

0 Threads

#38 11 years ago

What flavor of GTS do you have? 320 vs 640 mb is a big difference.




puffdadder

the really annoying Catholic

50 XP

12th May 2007

0 Uploads

3,121 Posts

0 Threads

#39 11 years ago

probably the 640 with those settings!




Guest

I didn't make it!

0 XP

 
#40 11 years ago

well i got the videocard and ram, it runs alright, only on medium tho. :( it sill looks great and i cant wait for the real thing. i have a question tho.... where do you get the assault scope, i played the whole thing twice and i cant find one.