Running UT2K3 in OpenGL - *FASTER* -1 reply

Please wait...

Metz

X2DesignStudios

50 XP

8th May 2003

0 Uploads

10 Posts

0 Threads

#1 15 years ago

Unreal Tournament 2003 is on default using the Direct3D Rendering Device, and doesnt let you choose OpenGL. Direct3D is suppose to be better looking but you can barly tell a diffrence versus OpenGL and OpenGL is a hell of lot faster. Here is how to change your game to run under OpenGL.

Open your UT2003.ini file inside your UT2003/Sytem/ folder (eg. C:\UT2003\System\) 3rd section down you should see a few lines that look like this:

RenderDevice=D3DDrv.D3DRenderDevice ;RenderDevice=Engine.NullRenderDevice ;RenderDevice=OpenGLDrv.OpenGLRenderDevice

The 1st line indicates which device to use. the other 2 with the ; in front show which other devices are avaible but are not being used. Now what you need to do is copy this part of the 3rd line: "OpenGLDrv.OpenGLRenderDevice". Then you need to paste it over "D3DDrv.D3DRenderDevice" on the first line and then replace the old 3rd line with "D3DDrv.D3DRenderDevice". So it should look exactly like this:

RenderDevice=OpenGLDrv.OpenGLRenderDevice ;RenderDevice=Engine.NullRenderDevice ;RenderDevice=D3DDrv.D3DRenderDevice

My frames went up from 60-70's to 100-150's and some higher depending on the map.

If you dont want to bother editing the ini or dont know what to do, i can send you a file with this already done, so all you have to do copy and paste.




Nemesis1611

"Will Frag For Bandwidth :D"

50 XP

11th February 2003

0 Uploads

16 Posts

0 Threads

#2 15 years ago

not excatly, ive all ready tweaked with the ut2003.ini files. the opengl did not increase fps, and i did try several maps. im running a 9800 pro (90+ fps, MAXED, 1024x768x32) and a geforce 4 ti 4200 (50+ fps, MAXED, 1024x768x32) and noticed on both that the fps dropped about 10 - 20 frames just panning around, and not only that if your in an outdoor map, u can see the sky animation moving...i wouldnt recommend using this tweak in the ini. file, unless u have disregard for your frames.




Metz

X2DesignStudios

50 XP

8th May 2003

0 Uploads

10 Posts

0 Threads

#3 15 years ago

well first, i have vertical sync off in both direct 3d and open gl. also make sure your fps cap=false, or you will be stuck on 90 fps... i average over 100 on every map and drop to 80's only like 1 or 2 with lots going on. im running a geforce ti 4200 8x agp




Nemesis1611

"Will Frag For Bandwidth :D"

50 XP

11th February 2003

0 Uploads

16 Posts

0 Threads

#4 15 years ago

ive also turned off the fps cap and the vertical sync but i am running the geforce ti on 4x agp, but the 9800 pro is on 8x....




Str8tKiller

I don't spend enough time here

50 XP

7th July 2003

0 Uploads

17 Posts

0 Threads

#5 15 years ago

time for a new computer!




Nemesis1611

"Will Frag For Bandwidth :D"

50 XP

11th February 2003

0 Uploads

16 Posts

0 Threads

#6 15 years ago

ehhhh???




1/2lunatic

I'm too cool to Post

50 XP

9th July 2003

0 Uploads

3 Posts

0 Threads

#7 15 years ago

Strange...for me I found OpenGL to be too slow. I gain about 10 fps in about 3 maps though. I remember one was DM-Nirvana][ . Why I gained in there I have no clue. I'll stick to D3D.




nnn

The Internet ends at GF

50 XP

14th March 2003

0 Uploads

110 Posts

0 Threads

#8 15 years ago

I got 20-30 more frames using openGL over D3D. Maybe the only difference is hardware?:confused:




Jeff Über Admin

I am a mean boss ⬆️⬆️⬇️⬇️⬅️➡️⬅️➡️🅱🅰

184,632 XP

6th April 2000

0 Uploads

14,591 Posts

1,534 Threads

#9 15 years ago

it all depends on your graphics card you're using and the support that would be in the video drivers.


Product Manager | GameFront.com




Nemesis1611

"Will Frag For Bandwidth :D"

50 XP

11th February 2003

0 Uploads

16 Posts

0 Threads

#10 15 years ago

im running the lastest drivers with a Radeon 9800 pro and it still dropped....it doesnt make it run faster...