Any Shader love for ATI? -1 reply

  • 1
  • 2

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

I have an HD2600pro 512.

All of the shader and Paralax mods I have downloaded look HORRID.

Lots of glitches, missing textures, light problems, you name it.

This is on a fresh install of Doom 3 + RoE. Patch 1.3 WinXP SP2 and yes, EVERYTHING has been updated (Drivers\Bios etc ad nauseum) and thouroughly tested. Vanilla D3 looks as good it can for sure.

Anyway...

Load the same mods on my buddies box with an 8800 and they all look great.

So, I'm thinking it's an ATI driver problem. Unfortunately the only driver I can get to work for this card are the latest OMEGA drivers.

Have I missed something or are ATI users just kinda screwed on these mods?




Dafama2k7

I follow teh Moo!

50 XP

28th September 2006

0 Uploads

622 Posts

0 Threads

#2 10 years ago

If someone can tell me some page that explains how to take the ATI exclusive possibilities, if any, i will be glad to make an ATI only updated shader. :D




Xaijin

GF makes me horny

50 XP

2nd August 2006

0 Uploads

83 Posts

0 Threads

#3 10 years ago

have you tried simply renaming *_ati to the default names in the vfp file?




Guest

I didn't make it!

0 XP

 
#4 10 years ago

Sorry Xaijin, I have no idea what you just said. Is there something I can change to get Shader Mods to work? I don't know the D3 engine very well, I must admit. But I can do pretty much anything as far as file manipulation. If there's something I can tweak, shoot me a link please? I've been scouring the forums for 2 days now and haven't found a reference to a vfp file fixing renderer issues.




Guest

I didn't make it!

0 XP

 
#5 10 years ago

Found what you were talking about Xaijin, copied and renamed vfp files, seems to have cleared up all but the most annoying bug. Transparent textures have become inverse mirrors.




Xaijin

GF makes me horny

50 XP

2nd August 2006

0 Uploads

83 Posts

0 Threads

#6 10 years ago
Havoc One;4261439Found what you were talking about Xaijin, copied and renamed vfp files, seems to have cleared up all but the most annoying bug. Transparent textures have become inverse mirrors.

I think there's a new hotfix for catalyst 8.3 released a couple days ago.. might try dling than then dling 8.3




Guest

I didn't make it!

0 XP

 
#7 10 years ago

I might try that. Here's why I'm leary. I have one of the newish HD2600 XT 512mb AGP's. It doesn't work very well. OpenGL works fine with the Cat drivers, but D3D causes my PC to spontaneously reboot.... The only stable drivers I have found are the OMEGA 3.8.442's. Based on CAT 7.12 iirc. Although the original Cat 7.12's make my PC reboot when using D3D just like the 8.1+Hotfix series have. Weird huh? Looks like Visiontek has a new driver out for the 2000 series cards. Version 8.345. Might check those out as well. I'll update with results tomorrow.




Xaijin

GF makes me horny

50 XP

2nd August 2006

0 Uploads

83 Posts

0 Threads

#8 10 years ago

Since on of the hotfix bullet points is specifically AGP support, you're probably in good stead.




Guest

I didn't make it!

0 XP

 
#9 10 years ago

Nope, the new drivers don't work. Same issues with Doom3 Shader mods. All transparent textures invert the textures behind them and display them like a mirror. Normal D3 frames do increase about 5-10%. But that's of no use since D3D apps cause the PC to spontaneously reboot either instantly upon execution, or after a very short time. Dunno what else to try except an Nvidia card. Looks like ATI has really suffered under the merger with AMD... That really sucks. I've been running AMD\ATI combos for about 10 years now. (After my SLI 12MB Voodoo 2's were retired.) That might have to change.




Dafama2k7

I follow teh Moo!

50 XP

28th September 2006

0 Uploads

622 Posts

0 Threads

#10 10 years ago

Buy an NVidia gfx card if you can !




  • 1
  • 2