Mods and Doom 3 v1.3.1 -1 reply

Please wait...

r@gdoll_phys1cs

The Computer Geek

50 XP

20th January 2005

0 Uploads

21 Posts

0 Threads

#1 11 years ago

As we all know by now mods don't work with Doom 3 v1.3.1, but when I try to use Doom 3 v1.3 it says Error during initialization --------- Initializing Game ---------- gamename: baseDOOM-1 gamedate: May 10 2005 Initializing event system ...472 event definitions Initializing class hierarchy ...142 classes, 190688 bytes for event callbacks Initializing scripts --------- Game Map Shutdown ---------- -------------------------------------- ******************** ERROR: Error: file script/doom_events.script, line 980: Unknown event 'getIdealWeapon' ******************** Error during initialization Shutting down OpenGL subsystem ...wglMakeCurrent( NULL, NULL ): success ...deleting GL context: success ...releasing DC: success ...destroying window ...resetting display ...shutting down QGL ...unloading OpenGL DLL

What do I do? I really want to play the Brilliant Bloom and Brilliant Highlight mods but Doom 3 v1.3 won't even start.




Master Bob

Resident maniac.

50 XP

10th February 2006

0 Uploads

122 Posts

0 Threads

#2 11 years ago

Have you got the expansion pack installed? It can be unhappy sharing space with mods.

Also, did you actually try running Doom 3 with the patch before installing the mods? That could tell you if the patch installation went wrong.

Also, do the mod readme's say anything about what version of Doom 3 they run best with?




Dafama2k7

I follow teh Moo!

50 XP

28th September 2006

0 Uploads

622 Posts

0 Threads

#3 11 years ago

A new mod that enables to use mods that requieres the v1.3.0 is already made !!! Only have to place this small .pk4 in any mod that requires Doom 3 v1.3.0 !!!

Attention !!!...:

Remember that anyone that use it will need an old Doom3.exe v1.3.0 to run it !!!

http://www.megaupload.com/?d=7D3BMF70

This a way to make work mods that use a .dll old library that was maked for v1.3.0 or that uses they're own weapon_hangrenade.script or doom_events.script file, this things are newer and has different files on v1.3.1 and because of this they are incompatible, if you put this aaaa_doom_130.pk4 file on the mods you have some problems only, and you execute a shotcut that uses the Doom v1.3.0 executable, then you will be able to run it.

A good example of this is to try to execute the in_hell mod/sp maps, you will need to put my small mod .pk4 file on they're folder to be able to run it and also execute them with v1.3.0 Doom3.exe.

Another examples that need this would be...: D2forD3, Greentech and many more good mods that aren't updated to latest version because they use some Bloom effect in they're own .dll or something like this...




Ice Trey

Slightly cooler than you

50 XP

23rd March 2007

0 Uploads

73 Posts

0 Threads

#4 11 years ago

Dafama to the rescue as always =D ill be needing something like this soon cuss ive tried patch 1.31 and everything went down the drain and made me do a reinstall of doom3, so needless to say ill never go near that patch again, im sticking with 1.3