ATI problems with Doom 3 -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 13 years ago

I have an ATI Radeeon 9800 PRO with the 4.12 CATALYST driver installed, yet for some reason, i can only play D3 for a few mins before the game suddenly crashes and logs out without telling me WTF happened. There is no new update to fix this problem so what should i do? I WANT TO PLAY AGAIN! Please try and e-mail me so i can check more regularly at [email="from102003@yahoo.com"]from102003@yahoo.com[/email] thanx




glory77

Born yesterday but up all nite

50 XP

23rd August 2002

0 Uploads

454 Posts

0 Threads

#2 13 years ago

Did you have the 4.12 driver before, when you were able to play? Maybe downgrade to the previous CATALYST driver and see if that works.




Guest

I didn't make it!

0 XP

 
#3 13 years ago

i was able to play before, but im not gonna downgrade, even if it is for D3. besides, i have had problems in the past with it. Anyways, when i go to college in a few months im gettin a new laptop so ill just have to wait or until a new update comes out.




SnoopJeDi

We call this the BFG 9000.....

50 XP

17th December 2004

0 Uploads

94 Posts

0 Threads

#4 13 years ago

The Omega ATI Drivers are a reliable fix for this:

http://www.omegadrivers.net

Get the latest ATI Radeon drivers (i think he has a 4.12 version out) and install them.

I had the same problem until I installed the Omegadrivers and Doom3 runs like a dream now (although once or twice the desktop gamma in the Radlink that I use had to be re-locked, but thats not a big issue)

Hope it helps!




Guest

I didn't make it!

0 XP

 
#5 13 years ago

Okay, now in the past i have had some problems with installing ATI drivers. One such problem is that the frame rates on my PC would be so slow that when i right clicked, the menu would come up in several shades. Not only that, but i could not play my games. Does the file f*ck up anytime? if not, can you direct me to the site that you downloaded from?




Guest

I didn't make it!

0 XP

 
#6 13 years ago

Last i checked ATI released catalyst 5.1 .. why run 4.12?