I got an ERROR for the latest patch -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

urrent search path: C:\Program Files (x86)\Doom 3/base C:\Program Files (x86)\Doom 3\base\pak008.pk4 (3 files) C:\Program Files (x86)\Doom 3\base\pak007.pk4 (38 files) C:\Program Files (x86)\Doom 3\base\pak006.pk4 (48 files) C:\Program Files (x86)\Doom 3\base\pak005.pk4 (63 files) C:\Program Files (x86)\Doom 3\base\pak004.pk4 (5137 files) C:\Program Files (x86)\Doom 3\base\pak003.pk4 (4676 files) C:\Program Files (x86)\Doom 3\base\pak002.pk4 (6120 files) C:\Program Files (x86)\Doom 3\base\pak001.pk4 (8972 files) C:\Program Files (x86)\Doom 3\base\pak000.pk4 (2698 files) C:\Program Files (x86)\Doom 3\base\game03.pk4 (2 files) C:\Program Files (x86)\Doom 3\base\game02.pk4 (2 files) C:\Program Files (x86)\Doom 3\base\game01.pk4 (2 files) C:\Program Files (x86)\Doom 3\base\game00.pk4 (2 files) game DLL: 0x0 in pak: 0x0 file system initialized. -------------------------------------- ----- Initializing Decls ----- ------------------------------ ------- Initializing renderSystem -------- using ARB renderSystem renderSystem initialized. -------------------------------------- 5206 strings read from strings/english.lang Couldn't open journal files execing editor.cfg execing default.cfg execing DoomConfig.cfg couldn't exec autoexec.cfg 5206 strings read from strings/english.lang ----- Initializing Sound System ------ sound system initialized. -------------------------------------- ----- R_InitOpenGL ----- Initializing OpenGL subsystem ...registered window class ...registered fake window class ...initializing QGL ...calling LoadLibrary( 'opengl32' ): succeeded ...calling CDS: ok ...created window @ 0,0 (1280x1024) Initializing OpenGL driver ...getting DC: succeeded ...attempting to use stereo ...PIXELFORMAT 10 selected ...creating GL context: succeeded ...making context current: succeeded

------- Input Initialization ------- Initializing DirectInput... mouse: DirectInput initialized. keyboard: DirectInput initialized. ------------------------------------ sound: STEREO ...using GL_ARB_multitexture ...using GL_ARB_texture_env_combine ...using GL_ARB_texture_cube_map ...using GL_ARB_texture_env_dot3 ...using GL_ARB_texture_env_add ...using GL_ARB_texture_non_power_of_two ...using GL_ARB_texture_compression ...using GL_EXT_texture_filter_anisotropic maxTextureAnisotropy: 16.000000 ...using GL_1.4_texture_lod_bias X..GL_EXT_shared_texture_palette not found ...using GL_EXT_texture3D ...using GL_EXT_stencil_wrap ...using GL_NV_register_combiners ...using GL_EXT_stencil_two_side X..GL_ATI_fragment_shader not found ...using GL_ARB_vertex_buffer_object ...using GL_ARB_vertex_program ...using GL_ARB_fragment_program ...using EXT_depth_bounds_test ---------- R_NV20_Init ---------- -------------------------------------------- ----- R200_Init ----- Not available. ---------- R_ARB2_Init ---------- Available. Cg not available. -------------------------------------------- ---------- R_Exp_Init ---------- PARAM bloom0 = { 0.199501 }; PARAM bloom1 = { 0.176059 }; PARAM bloom2 = { 0.121004 }; PARAM bloom3 = { 0.064769 }; PARAM bloom4 = { 0.027000 }; PARAM bloom5 = { 0.008765 }; PARAM bloom6 = { 0.002216 }; PARAM bloom7 = { 0.000436 }; Available. -------------------------------------------- ----- R_ReloadARBPrograms ----- glprogs/test.vfp glprogs/test.vfp glprogs/interaction.vfp glprogs/interaction.vfp glprogs/bumpyEnvironment.vfp glprogs/bumpyEnvironment.vfp glprogs/ambientLight.vfp glprogs/ambientLight.vfp glprogs/shadow.vp glprogs/R200_interaction.vp glprogs/nv20_bumpAndLight.vp glprogs/nv20_diffuseColor.vp glprogs/nv20_specularColor.vp glprogs/nv20_diffuseAndSpecularColor.vp glprogs/environment.vfp glprogs/environment.vfp ------------------------------- using ARB_vertex_buffer_object memory using ARB2 renderSystem found DLL in pak file: C:\Program Files (x86)\Doom 3\base\game03.pk4/gamex86.dll copy gamex86.dll to C:\Program Files (x86)\Doom 3\base\gamex86.dll ******************** ERROR: wrong game DLL API version ******************** Error during initialization Shutting down OpenGL subsystem ...wglMakeCurrent( NULL, NULL ): success ...deleting GL context: success ...releasing DC: success ...destroying window ...resetting display ...shutting down QGL ...unloading OpenGL DLL

Is there a way to fix this?




Dafama2k7

I follow teh Moo!

50 XP

28th September 2006

0 Uploads

622 Posts

0 Threads

#2 10 years ago

I see that you are using a Doom 3 patched to v1.3.1, so maybe you are trying to use the gamex86.dll library that is copied from the game003.pk4 every time you starts D3 on the mod folder you use or base folder and this error can be caused maybe if you are using an older Doom3.exe from v1.3.0 or older version.

Or may be you have the "Doom 3/base/gamex86.dll" library file write-disabled so D3 cannot replace it with the v1.3.1 one present on the game003.pk4 compressed official file, try removing that gamex86.dll library file on the base folder, do not worry, it will be replaced with the correct file as you start D3 again.

Warning !!!...: Make Backups of specially any .exe, .dll and .pk4 files, it is important for example to be able to run mods for both D3 v1.3.0 and v1.3.1 [COLOR=Red]Oh, and i hope that this time i am helping someone that have buy it the D3 game or any other game and/or ROE game expansion both legally (original), not a cracked couple free CDs full of viruses and no manuals, think on it, the programmers and artists worked hard on this game for many years, so, NO HELP, NO SUPPORT, NO RIGHTS AND NO MODS TO HACKERS, BUY THE GAME !!! [/COLOR]




Guest

I didn't make it!

0 XP

 
#3 10 years ago

Thanks Dafama2k7 i'll check this out I bought doom 3