Texture Error DOOM 3 -1 reply

Please wait...

Rai-Sohe

I'm too cool to Post

50 XP

2nd July 2005

0 Uploads

18 Posts

0 Threads

#1 14 years ago

Hello all this is my first ever post... I am raelly hoping someone will enlighten me and help me eradicate this problem... Whenever i play Doom 3 where ever there is meant to be a shadow on and model in game, the texture is replaced by a red and black checkered effect. It is so bad i am unable to play the game at all. I have had D3 since Friday last week and haven't played it once... does any one else feel my pain? I have created a small website based on this problem, been in touch with MSI and ATi and still no joy... I have ALL (and i mean ALL) the latest drivers for chipset, VGA, catalyst betas ect NO joy whatsoever. I did read some where that D3 uses some kind of compressed textures and theer are certain things you can change in teh D3Config.. probelm i i dont know what to edit. I also experience the same effect now problem as many other Radeon XT9800 ysers have seen on top of this checker problem.

caliguyDarthVedius: "I was just wondering if anyone else has experienced a problem while playing the game where there are little white and red dots that flash on the screen. I am using a Radeon XT PRO 9800 video card with the new drivers and these dots keep flashing on the screen while playing the game." I am having the same problem sad%20%28frown%29.gif, and using the same video card. My system is not overclocked. Any solutions? Caliguy

I am trying to paste a link to a website i have made solely for this problem but the forum will not allow me.. pls view my profile to obtain this address (my PWP). It contains images and a full dxdiag. If anyone anywhere in the world can help, i would be eternally grateful.... Thanks in advance. CYON :( Mobo: Asus A7V8X CPU: AMD Athlon 3000+ (Barton/ 512 Cache) RAM: 1024 Kingston DDR PC3200 (2x 512) VGA: MSI RADEON 9800XT Pro TD128 (Ati chip) Sound: CReative 1024 Live player HDD: Fujitsu 7200rpm 120GB x2 POWER & Case: Antec TruPOwer 480 with Aluminium Case and 9 fans




Ultima2x

Addicted to GF

50 XP

27th June 2004

0 Uploads

283 Posts

0 Threads

#2 14 years ago

To fix the white dots, you need to underclock your card. I suggest using ATi tool. I'm not sure about checkers on playershadowing, i'll have to look into it. But i know 9800 cards have an issue with overperforming, so some people's cards get far too hot causing the white dots to appear. Just underclock your card little by little till the problem is fixed.

Another variable to tinker with to try and solve your problem is to download the latest ATi Omega Drivers, www.omegadrivers.net .

:::WARNING: Omega Drivers are not official drivers, use at your own risk::::

With that said... me and many many other people use omega drivers without a hitch.




Rai-Sohe

I'm too cool to Post

50 XP

2nd July 2005

0 Uploads

18 Posts

0 Threads

#3 14 years ago

ok ill try the underclock thingy.... ur the 2nd person to tell me that now. thanks.




Rai-Sohe

I'm too cool to Post

50 XP

2nd July 2005

0 Uploads

18 Posts

0 Threads

#4 14 years ago

Underclocking the card has not resulted in a change i underclocked it to 250MHz and still getting the snow effect... any otehr ideas?




Ultima2x

Addicted to GF

50 XP

27th June 2004

0 Uploads

283 Posts

0 Threads

#5 14 years ago

My next guess would be that your powersupply is too small to sustain your card. But after reading your specs 480w should be more than fine.

Perhaps you could take a screenshot so i could get a better idea of the problem? (preferrably the checkard part.. i've already seen the white dots)




Rai-Sohe

I'm too cool to Post

50 XP

2nd July 2005

0 Uploads

18 Posts

0 Threads

#6 14 years ago

Hey Ultima... if u view my profile and goto my homepage i have pasted screens on there... pls let me knwo what you think.. Thanks for all your help mate :)




Ultima2x

Addicted to GF

50 XP

27th June 2004

0 Uploads

283 Posts

0 Threads

#7 14 years ago

Thank you for being as informative as possible :bows: You don't have the latest DirectX, the latest is 9.0c (some people will tell you it makes no difference between 9.0b if blah blah blah, but download DirectX 9.0c anyways) http://www.microsoft.com/downloads/details.aspx?FamilyID=0a9b6820-bfbb-4799-9908-d418cdeac197&DisplayLang=en

I'm going through your specs now, hopefully it's that simple tho.

Anyone else trying to help, to make it simple. Specs and images are on http://www.mkolovos.pwp.blueyonder.co.uk/ (took me a while to load the page)




Rai-Sohe

I'm too cool to Post

50 XP

2nd July 2005

0 Uploads

18 Posts

0 Threads

#8 14 years ago

funny u mentioned the DirectX point cos i just realised that too, have installed it and still no joy... my pc now has DX9.0c installed.

But here is something worth noting!!! i know i previously said that the problem is not occuring in other games but after a bit more thorough investigation i realise that the checkered effect is also showing in FarCry whilst on the water (tho not as noticeable and not red..). Im thinking it is a texture blending error Trilinear or Bilinear filtering?? where 2 textures overlap to give a deeper image. this would make sense for the farcry problem as im sure the water is created by multiple layers of textures and would make sense for the D3 error as shadows are usually created as an identical texture but with opacity and darker contrast settings... am i talking Shite or am i making sense... who knows..




The Masta

I´m to good for you

50 XP

9th August 2005

0 Uploads

16 Posts

0 Threads

#9 14 years ago

rage3d forums (Games DOOM3/Half-Life2 Sub Forum) driverheaven forums (Radeon Display Drivers) Look for the topic "DOOM 3 Artifacts Revisited!". (I couldn't use direct links due to Gaming Forums policy on spamming) :confused: