Little mods: desperate help -1 reply

  • 1
  • 2

Please wait...

Guest

I didn't make it!

0 XP

 
#1 12 years ago

Right i need a little help with making small mods. My rules: dont suggest wiki or relic i applied and they never sent me anything OK... I have managed to edit the pipline. ini folder and open the module. folder but how do i change the module. stuff? i tried but it doesnt let me (when the sounds on it makes that weird beep noice when errors occur) Also before hand my mod was in the Attribute Editor but now it isnt please help me! :(




Danimator

Dread thinks I'm a special person

50 XP

8th December 2004

0 Uploads

327 Posts

0 Threads

#2 12 years ago

We need more info to help you. Have you got all the mod tools? Have you set up your "my_mod" folder? Have you copied a set of luas into the datageneric folder and re-named as your "my_mod" folder? If you could see your "my_mod" in the the AE and now you can't you have probably messed up your pipeline ini file. post it here so we can see. Module files are pretty straight forward but post it here if you want help. If you have seen your mod in the AE you must have done most of the above but the more info you give us the better.




Sekmet

Fear my Pussy!

50 XP

7th July 2005

0 Uploads

770 Posts

0 Threads

#3 12 years ago

What are u useing to do this with, sounds like u's haven some probs, i edit all moule & pipeline stuff with notepad, it is so simple.




Guest

I didn't make it!

0 XP

 
#4 12 years ago

Right ill answer all of that now:

DanimatorHave you got all the mod tools?[/quote] Yes i do, version 1.41 they work perfectly and are infact the only ones that seem to work for me
DanimatorHave you set up your "my_mod" folder?[/quote] I did everthing the small 'tutorial' said ( the one you get with mod tools)
DanimatorHave you copied a set of luas into the datageneric folder and re-named as your "my_mod" folder?
Umm... i didnt know you needed to do this, Lua files are the ones named after units and abilities arnt they? [quote=Danimator]If you could see your "my_mod" in the the AE and now you can't you have probably messed up your pipeline ini file. post it here so we can see?
I'm afraid its on a different PC sorry, i have set it up correctly but i will post it here soon [quote=Danimator]Module files are pretty straight forward but post it here if you want help. If you have seen your mod in the AE you must have done most of the above but the more info you give us the better.

I can open the Module. folder and it opens something like a notepad document. However i cannot change any letters from it. Thanks and now ill go check all pipeline and module. folders and everything else Right i cant edit it, MODERATORS!! this keeps happening it needs to be sorted please sorry for the double post though. Here is the pipeline.ini document ; NOTE: Replace "my_mod" with the name of your mod folder below! [project:MOD] Description = MOD DataSource = ModTools\DataSrc\MOD DataIntermediate = ModTools\DataInt\MOD DataGeneric = ModTools\DataGeneric\MOD DataBurn = MOD DataFinal = MOD\Data DataExtra = LocaleFolder = MOD\Locale\English Parent = WXP DataSourceShared = ModTools\DataSrc\MOD DataPreview = AttrLoc = and here is a all of the module. folder [global] UIName = My_Mod Description = My Super Duper Mod for Dawn of War DllName = W40kMod ModFolder = My_Mod ModVersion = 1.0 TextureFE = Art/UI/Textures/My_Mod.tga DataFolder.1 = Data RequiredMod.1 = W40k[global] UIName = My_Mod Description = My Super Duper Mod for Dawn of War DllName = W40kMod ModFolder = My_Mod ModVersion = 1.0 TextureFE = Art/UI/Textures/My_Mod.tga DataFolder.1 = Data RequiredMod.1 = W40k there you are, any problems there? i copied all WXP files into My Mod (which is just called: MOD) as i said i cant change the module. folder, i changed the pipline.ini and added the luas and now my mod project is available when i open the Attribute Editor




Danimator

Dread thinks I'm a special person

50 XP

8th December 2004

0 Uploads

327 Posts

0 Threads

#5 12 years ago

Good news is it looks ok and sounds like you have got the basics right. Pipeline.ini is fine and it proves it if you can now see you mod. If you have something in the AE you must have the luas in your datageneric/Mod folder, did you copy and rename the My_Mod folder or the WXP folder or the w40k folder to get your set of luas? If you are using wxp luas and/or want to make a mod for wxp then maybe you should change w40k to WXP in the module file. Your module file only needs to be: [global] UIName = My_Mod Description = My Super Duper Mod for Dawn of War DllName = W40kMod ModFolder = My_Mod ModVersion = 1.0 TextureFE = Art/UI/Textures/My_Mod.tga DataFolder.1 = Data RequiredMod.1 = W40k

or

[global] UIName = My_Mod Description = My Super Duper Mod for Dawn of War DllName = WXPMod ModFolder = My_Mod ModVersion = 1.0 TextureFE = Art/UI/Textures/My_Mod.tga DataFolder.1 = Data RequiredMod.1 = WXP RequiredMod.2 = w40k

which brings us to your strange problem....you can't edit your module file. Is it a lua file? Sometimes, depending on how you open them, you can change them into text files....you don't want to do this and if you can't edit it maybe you have made it a read only text file? If you have, make another copy as a lua file and delete the text file. Let us know if this helps.




Guest

I didn't make it!

0 XP

 
#6 12 years ago

right ok, im not sure about looking for lua files, but ill give you a run down of what happens when i open it: I have to put it in to a winrar compressed document to open the module. folder otherwise it just loads DOWWA, when i do open it it is classified as viewing it (does that mean i cant change it?) i can view via DOS or Windows texts, (i dont have a clue) it opens as a notepad document with the little line where you can type that flashes. However, when i do type in a letter it doesnt do it, it is called: MOD.Module and is a Module Folder type. how do i get it to be a lua file? Edit: Ive got it all sorted guys!! thank you all very much look out on filefront for my small SM mod and expect your names to be in the credits! :p Edit: I get over 1 problem and another pops up!!! i can now do everything with my mod but when i edit something on the AE it automatically changes every ability and so i crashes! any ideas?!?




IBBoard

Artificer Minoris

50 XP

30th January 2006

0 Uploads

807 Posts

0 Threads

#7 12 years ago

What does it say in the warning.logs file (or the warning1.logs - if you're using the AE then you'll end up with both)




Guest

I didn't make it!

0 XP

 
#8 12 years ago

right here is the warnings.log: 18:23:21.47 ATTRIBUTEEDITOR started at 2006-05-04 18:23 18:23:21.47 OS NT 5.1, 512MB Physical Memory 18:23:21.47 RUN-OPTIONS 18:23:21.47 WORKING-DIR C:\Program Files\THQ\Dawn of War 18:23:21.47 18:23:21.47 attributeeditor.c/64:!AttributeEditor -- Starting... 18:25:40.23 2334 attribute files loaded, 0 failures 18:25:41.13 luaconfigsave.c/648:!Failed to load lua file 'TOOL:designmode.lua' and here is the warnings.log1: 17:25:23.36 W40KWA started at 2006-05-04 17:25 17:25:23.36 OS NT 5.1, 512MB Physical Memory 17:25:23.36 RUN-OPTIONS 17:25:23.36 WORKING-DIR C:\Program Files\THQ\Dawn of War 17:25:23.36 17:25:33.62 MATHBOX -- Version=5, Cpu=AMD Athlon:f=6,m=8, Mode=SSE 17:25:33.62 GAME -- Warhammer, 1.40, Build 78258.63110 17:25:33.62 GAME -- Available memory: 511MB RAM, 1200MB Pagefile 17:25:33.62 State::State - set socket send buffer to 131072 17:25:33.62 State::State - set socket receive buffer to 131072 17:25:33.62 HostState - 127.0.0.1:6112 / 127.0.0.1:6112 17:25:33.62 Session : Now Host 17:25:33.62 Session : We are now a Host 17:25:33.62 PeerState - 127.0.0.1:6112 / 127.0.0.1:6112 17:25:33.62 PeerState::ConnectCallbackHost - connecting to host at 255.255.255.255:6112 17:25:33.62 GSTransport::Connect - GT2AddressError 17:25:33.62 GSTransport::State::SendSystemEvent - error sending to (255.255.255.255:6112 -1 6112) using socket (error 10065) 17:25:33.62 SPOOGE - Driver[Dx9 : Hardware TnL] on adapter[0], version[4,32] 17:25:33.62 SPDx9 -- Driver Name = ati2dvag.dll Device = \\.\DISPLAY1 Desc = RADEON 9200 SERIES 17:25:33.62 SPDx9 -- Driver Vendor = 0x1002 Device = 0x5961 SubSys = 0x7C13174B Rev = 0x0001 17:25:33.62 SPDx9 -- Driver Version Product = 0x0006 Version = 0x000E SubVersion = 0x000A Build = 0x190E (6414) 17:25:33.62 SPDx9 -- Driver GUID = {D7B71EE2-1A21-11CF-F56D-195CA0C2CB35} 17:25:33.62 SPOOGE -- 236.00MB available texture memory 17:25:33.62 SPOOGE -- 236.00MB available texture memory 17:25:33.62 GAME -- Beginning FE 17:25:33.90 MOVIE -- Opening movie 'movies:dxp_relic_intro.lua' 17:25:40.89 MOVIE -- Closing movie 'movies:dxp_relic_intro.lua' 17:25:40.89 MOVIE -- Opening movie 'movies:dow_intro.lua' 17:25:40.94 MOVIE -- Closing movie 'movies:dow_intro.lua' 17:25:50.52 MOD -- (mod manager) Failed to read field from MOD definition file 'chaos_ext.module' 17:25:50.52 MOD -- (mod manager) Mod folder 'My_Mod' does not exist. 17:25:50.52 MOD -- Initializing Mod necrons, 1.0 17:25:50.52 MOD -- Warning: Failed to load archive 'W40k\W40kDataGOTY.sga' 17:25:50.52 MOD -- Warning: Failed to open folder 'WXP\Locale\english\Data'. 17:25:50.52 MOD -- Warning: Failed to open folder 'WXP\Data_Shared_Textures\Full'. 17:25:50.52 MOD -- Warning: Failed to open folder 'WXP\Data_Sound\Med'. 17:25:50.52 MOD -- Warning: Failed to open folder 'WXP\Data_Music'. 17:25:50.52 MOD -- Warning: Failed to open folder 'WXP\Data_Whm\High'. 17:25:50.52 MOD -- Warning: Failed to open folder 'W40k\Locale\english\Data'. 17:25:50.52 MOD -- Warning: Failed to open folder 'W40k\Data_Shared_Textures\Full'. 17:25:50.52 MOD -- Warning: Failed to open folder 'W40k\Data_Sound\Med'. 17:25:50.52 MOD -- Warning: Failed to open folder 'W40k\Data_Whm\High'. 17:25:50.52 SIM -- Attempted to load duplicate blueprint, EBPs\Races\npc\Troops\NECRON_WARRIOR.RGD (219) 17:25:50.52 GAME -- Warning: Skipping MOD 'wxp' campaign 'DATA:SCENARIOS\SP\WXP_DISORDER.CAMP'. 17:25:50.52 GAME -- Warning: Skipping MOD 'wxp' campaign 'DATA:SCENARIOS\SP\WXP_ORDER.CAMP'. 17:25:50.52 GAME -- Warning: Skipping MOD 'w40k' campaign 'DATA:SCENARIOS\SP\DAWNOFWAR.CAMP'. 17:25:58.82 GAME -- Using player profile Matt 17:26:08.81 GAME -- Restarting with mod 'sm_mini_mod'... 17:26:08.81 GAME -- Ending FE 17:26:08.81 MOD -- Shutting down Mod 'necrons'... 17:26:10.47 SPOOGE -- 233.00MB available texture memory 17:26:10.47 SPOOGE -- 233.00MB available texture memory 17:26:10.47 GAME -- Available memory: 511MB RAM, 1200MB Pagefile 17:26:10.47 HostState - 127.0.0.1:6112 / 127.0.0.1:6112 17:26:10.47 Session : Now Host 17:26:10.47 Session : We are now a Host 17:26:10.47 PeerState - 127.0.0.1:6112 / 127.0.0.1:6112 17:26:10.47 PeerState::ConnectCallbackHost - connecting to host at 255.255.255.255:6112 17:26:10.47 GSTransport::Connect - GT2AddressError 17:26:10.47 GSTransport::State::SendSystemEvent - error sending to (255.255.255.255:6112 -1 6112) using socket (error 10065) 17:26:10.47 SPOOGE - Driver[Dx9 : Hardware TnL] on adapter[0], version[4,32] 17:26:10.47 SPDx9 -- Driver Name = ati2dvag.dll Device = \\.\DISPLAY1 Desc = RADEON 9200 SERIES 17:26:10.47 SPDx9 -- Driver Vendor = 0x1002 Device = 0x5961 SubSys = 0x7C13174B Rev = 0x0001 17:26:10.47 SPDx9 -- Driver Version Product = 0x0006 Version = 0x000E SubVersion = 0x000A Build = 0x190E (6414) 17:26:10.47 SPDx9 -- Driver GUID = {D7B71EE2-1A21-11CF-F56D-195CA0C2CB35} 17:26:10.47 SPOOGE -- 236.00MB available texture memory 17:26:10.47 SPOOGE -- 236.00MB available texture memory 17:26:10.47 GAME -- Beginning FE 17:26:14.74 MOD -- Initializing Mod sm_mini_mod, 1.0 17:26:14.74 MOD -- Warning: Failed to load archive 'W40k\W40kDataGOTY.sga' 17:26:14.74 MOD -- Warning: Failed to open folder 'WXP\Locale\english\Data'. 17:26:14.74 MOD -- Warning: Failed to open folder 'WXP\Data_Shared_Textures\Full'. 17:26:14.74 MOD -- Warning: Failed to open folder 'WXP\Data_Sound\Med'. 17:26:14.74 MOD -- Warning: Failed to open folder 'WXP\Data_Music'. 17:26:14.74 MOD -- Warning: Failed to open folder 'WXP\Data_Whm\High'. 17:26:14.74 MOD -- Warning: Failed to open folder 'W40k\Locale\english\Data'. 17:26:14.74 MOD -- Warning: Failed to open folder 'W40k\Data_Shared_Textures\Full'. 17:26:14.74 MOD -- Warning: Failed to open folder 'W40k\Data_Sound\Med'. 17:26:14.74 MOD -- Warning: Failed to open folder 'W40k\Data_Whm\High'. 17:26:14.74 MOD -- Fatal Data Error for 'modifiers\reload_time_weapon_modifier.lua' - the target weapon type 'TEST' does not exist! 17:26:14.74 WXP Mod Init -- Failed load for step: 'MOD Data Validation' 17:26:14.74 Mod Interface Init -- Failed load for step: 'Mod Init' 17:26:14.74 GAME -- Failed to initialize MOD 'sm_mini_mod'! 17:26:14.74 MOD -- Initializing Mod necrons, 1.0 17:26:14.74 MOD -- Warning: Failed to load archive 'W40k\W40kDataGOTY.sga' 17:26:14.74 MOD -- Warning: Failed to open folder 'WXP\Locale\english\Data'. 17:26:14.74 MOD -- Warning: Failed to open folder 'WXP\Data_Shared_Textures\Full'. 17:26:14.74 MOD -- Warning: Failed to open folder 'WXP\Data_Sound\Med'. 17:26:14.74 MOD -- Warning: Failed to open folder 'WXP\Data_Music'. 17:26:14.74 MOD -- Warning: Failed to open folder 'WXP\Data_Whm\High'. 17:26:14.74 MOD -- Warning: Failed to open folder 'W40k\Locale\english\Data'. 17:26:14.74 MOD -- Warning: Failed to open folder 'W40k\Data_Shared_Textures\Full'. 17:26:14.74 MOD -- Warning: Failed to open folder 'W40k\Data_Sound\Med'. 17:26:14.74 MOD -- Warning: Failed to open folder 'W40k\Data_Whm\High'. 17:26:14.74 SIM -- Attempted to load duplicate blueprint, EBPs\Races\npc\Troops\NECRON_WARRIOR.RGD (219) 17:26:14.74 GAME -- Warning: Skipping MOD 'wxp' campaign 'DATA:SCENARIOS\SP\WXP_DISORDER.CAMP'. 17:26:14.74 GAME -- Warning: Skipping MOD 'wxp' campaign 'DATA:SCENARIOS\SP\WXP_ORDER.CAMP'. 17:26:14.74 GAME -- Warning: Skipping MOD 'w40k' campaign 'DATA:SCENARIOS\SP\DAWNOFWAR.CAMP'. 17:26:16.71 GAME -- Using player profile Matt 17:26:24.67 GAME -- Ending FE 17:26:24.67 MOD -- Shutting down Mod 'necrons'... 17:26:24.89 SPOOGE -- 233.00MB available texture memory 17:26:24.89 SPOOGE -- 233.00MB available texture memory 17:26:24.94 Application closed without errors

I took out the parts were it said my name because i didnt want it online :) but that wont affect anything thanks guys




Danimator

Dread thinks I'm a special person

50 XP

8th December 2004

0 Uploads

327 Posts

0 Threads

#9 12 years ago
17:26:14.74 MOD -- Fatal Data Error for 'modifiers\reload_time_weapon_modifier.lua' - the target weapon type 'TEST' does not exist!

You've got a modifier pointing to a nonexistent or faulty weapon type. The first warnings log looks very short, was there more than this?




Guest

I didn't make it!

0 XP

 
#10 12 years ago

no, thats all of it. how can i fix that missing modifier?




  • 1
  • 2