Mod Idea: Armoured Companies -1 reply

Please wait...

Andon

Armoured Company Addict

50 XP

16th June 2006

0 Uploads

91 Posts

0 Threads

#21 14 years ago

alrighty then. Got it all cloned and set up for the basics.

Created the Salamander, but i've got no idea on how to change the weapons loadout, squad carrying capacity, Name in game, etc. I know this is done through AE, somewhere, but i've got no clue where.




Andon

Armoured Company Addict

50 XP

16th June 2006

0 Uploads

91 Posts

0 Threads

#22 14 years ago

alright, so i fired up WA, and activated the AC mod.

What it did was load up, thn say 'Failed to activate specified game' or something. What does this ususally indicate?




IBBoard

Artificer Minoris

50 XP

29th January 2006

0 Uploads

807 Posts

0 Threads

#23 14 years ago

It usually indicates a bug/error in the mod. Run it up again, activate it again, let it fail again and then close down. Open up the warnings.log file (in your DoW folder) and either fix the problem it lists or else post the log content here if you don't know what the problem is.




Andon

Armoured Company Addict

50 XP

16th June 2006

0 Uploads

91 Posts

0 Threads

#24 14 years ago

here's the warning file. it seems like i missed on editing some things when cloning the Guard race, but i'm pretty sure i did everything right....

10:18:11.33 W40KWA started at 2006-06-24 10:18 10:18:11.33 OS NT 5.1, 640MB Physical Memory 10:18:11.33 RUN-OPTIONS 10:18:11.33 WORKING-DIR C:\Program Files\THQ\Dawn Of War 10:18:11.33 USER Owner 10:18:11.33 10:18:35.96 MATHBOX -- Version=5, Cpu=INTEL Pentium-IV:f=15,m=1, Mode=SSE 10:18:35.96 FILESYSTEM -- filepath failure, path does not exist 'Engine\Locale\english\Data' 10:18:35.96 GAME -- Warning: Failed to map folder 'Engine\Locale\english\Data'. 10:18:35.96 GAME -- Warhammer, 1.41, Build 82463.63883 10:18:35.96 GAME -- Available memory: 639MB RAM, 1512MB Pagefile 10:18:35.96 State::State - set socket send buffer to 131072 10:18:35.96 State::State - set socket receive buffer to 131072 10:18:35.96 HostState - 192.168.1.101:6112 / 192.168.1.101:6112 10:18:35.96 Session : Now Host 10:18:35.96 Session : We are now a Host 10:18:35.96 PeerState - 192.168.1.101:6112 / 192.168.1.101:6112 10:18:35.96 PeerState::ConnectCallbackHost - connecting to host at 255.255.255.255:6112 10:18:35.96 GSTransport::Connect - GT2AddressError 10:18:35.96 SPOOGE - Driver[Dx9 : Hardware TnL] on adapter[0], version[4,32] 10:18:35.96 SPDx9 -- Driver Name = nv4_disp.dll Device = \\.\DISPLAY1 Desc = NVIDIA GeForce2 MX 100/200 (Microsoft Corporation) 10:18:35.96 SPDx9 -- Driver Vendor = 0x10DE Device = 0x0111 SubSys = 0x002C1545 Rev = 0x00B2 10:18:35.96 SPDx9 -- Driver Version Product = 0x0006 Version = 0x000E SubVersion = 0x000A Build = 0x1629 (5673) 10:18:35.96 SPDx9 -- Driver GUID = {D7B71E3E-4251-11CF-DC60-262013C2CB35} 10:18:35.96 SPOOGE -- 78.00MB available texture memory 10:18:35.96 SPOOGE -- 78.00MB available texture memory 10:18:35.96 GAME -- Beginning FE 10:18:36.24 MOVIE -- Opening movie 'movies:dxp_relic_intro.lua' 10:18:39.58 MOVIE -- Closing movie 'movies:dxp_relic_intro.lua' 10:18:39.58 MOVIE -- Opening movie 'movies:dow_intro.lua' 10:18:40.30 MOVIE -- Closing movie 'movies:dow_intro.lua' 10:18:56.99 MOD -- Initializing Mod wxp, 1.0 10:18:56.99 MOD -- Warning: Failed to open folder 'WXP\Locale\english\Data'. 10:18:56.99 MOD -- Warning: Failed to open folder 'WXP\Data_Shared_Textures\Full'. 10:18:56.99 MOD -- Warning: Failed to open folder 'WXP\Data_Sound\Low'. 10:18:56.99 MOD -- Warning: Failed to open folder 'WXP\Data_Music'. 10:18:56.99 MOD -- Warning: Failed to open folder 'WXP\Data_Whm\Medium'. 10:18:56.99 MOD -- Warning: Failed to open folder 'W40k\Locale\english\Data'. 10:18:56.99 MOD -- Warning: Failed to open folder 'W40k\Data_Shared_Textures\Full'. 10:18:56.99 MOD -- Warning: Failed to open folder 'W40k\Data_Sound\Low'. 10:18:56.99 MOD -- Warning: Failed to open folder 'W40k\Data_Whm\Medium'. 10:18:56.99 GAME -- Warning: Skipping MOD 'w40k' campaign 'DATA:SCENARIOS\SP\DAWNOFWAR.CAMP'. 10:19:08.35 GAME -- Using player profile Andon 10:19:25.19 GAME -- Restarting with mod 'ac'... 10:19:25.19 GAME -- Ending FE 10:19:25.19 MOD -- Shutting down Mod 'wxp'... 10:19:33.05 SPOOGE -- 78.00MB available texture memory 10:19:33.05 SPOOGE -- 78.00MB available texture memory 10:19:33.05 GAME -- Available memory: 639MB RAM, 1512MB Pagefile 10:19:33.05 HostState - 192.168.1.101:6112 / 192.168.1.101:6112 10:19:33.05 Session : Now Host 10:19:33.05 Session : We are now a Host 10:19:33.05 PeerState - 192.168.1.101:6112 / 192.168.1.101:6112 10:19:33.05 PeerState::ConnectCallbackHost - connecting to host at 255.255.255.255:6112 10:19:33.05 GSTransport::Connect - GT2AddressError 10:19:33.05 SPOOGE - Driver[Dx9 : Hardware TnL] on adapter[0], version[4,32] 10:19:33.05 SPDx9 -- Driver Name = nv4_disp.dll Device = \\.\DISPLAY1 Desc = NVIDIA GeForce2 MX 100/200 (Microsoft Corporation) 10:19:33.05 SPDx9 -- Driver Vendor = 0x10DE Device = 0x0111 SubSys = 0x002C1545 Rev = 0x00B2 10:19:33.05 SPDx9 -- Driver Version Product = 0x0006 Version = 0x000E SubVersion = 0x000A Build = 0x1629 (5673) 10:19:33.05 SPDx9 -- Driver GUID = {D7B71E3E-4251-11CF-DC60-262013C2CB35} 10:19:33.05 SPOOGE -- 78.00MB available texture memory 10:19:33.05 SPOOGE -- 78.00MB available texture memory 10:19:33.05 GAME -- Beginning FE 10:20:00.23 MOD -- Initializing Mod ac, 1.0 10:20:00.23 MOD -- Warning: Failed to open folder 'WXP\Locale\english\Data'. 10:20:00.23 MOD -- Warning: Failed to open folder 'WXP\Data_Shared_Textures\Full'. 10:20:00.23 MOD -- Warning: Failed to open folder 'WXP\Data_Sound\Low'. 10:20:00.23 MOD -- Warning: Failed to open folder 'WXP\Data_Music'. 10:20:00.23 MOD -- Warning: Failed to open folder 'WXP\Data_Whm\Medium'. 10:20:00.23 MOD -- Warning: Failed to open folder 'W40k\Locale\english\Data'. 10:20:00.23 MOD -- Warning: Failed to open folder 'W40k\Data_Shared_Textures\Full'. 10:20:00.23 MOD -- Warning: Failed to open folder 'W40k\Data_Sound\Low'. 10:20:00.23 MOD -- Warning: Failed to open folder 'W40k\Data_Whm\Medium'. 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_infantry' does not exist! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_hq' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_hq_1' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_infantry' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_kasrkin_quarters' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_listening_post' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_list_post_1' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_hq' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_ministorum_temple' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_infantry' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_ogryn_quarters' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_hq' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_telepathica_temple' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_hq' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_turret' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_hq' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_vindicare_temple' pre-requisites! 10:20:00.23 WXP Mod Init -- Failed load for step: 'MOD Data Validation' 10:20:00.23 Mod Interface Init -- Failed load for step: 'Mod Init' 10:20:00.23 GAME -- Failed to initialize MOD 'ac'! 10:20:00.23 MOD -- Initializing Mod wxp, 1.0 10:20:00.23 MOD -- Warning: Failed to open folder 'WXP\Locale\english\Data'. 10:20:00.23 MOD -- Warning: Failed to open folder 'WXP\Data_Shared_Textures\Full'. 10:20:00.23 MOD -- Warning: Failed to open folder 'WXP\Data_Sound\Low'. 10:20:00.23 MOD -- Warning: Failed to open folder 'WXP\Data_Music'. 10:20:00.23 MOD -- Warning: Failed to open folder 'WXP\Data_Whm\Medium'. 10:20:00.23 MOD -- Warning: Failed to open folder 'W40k\Locale\english\Data'. 10:20:00.23 MOD -- Warning: Failed to open folder 'W40k\Data_Shared_Textures\Full'. 10:20:00.23 MOD -- Warning: Failed to open folder 'W40k\Data_Sound\Low'. 10:20:00.23 MOD -- Warning: Failed to open folder 'W40k\Data_Whm\Medium'. 10:20:00.23 GAME -- Warning: Skipping MOD 'w40k' campaign 'DATA:SCENARIOS\SP\DAWNOFWAR.CAMP'. 10:20:08.23 GAME -- Using player profile Andon 10:20:16.73 GAME -- Ending FE 10:20:16.73 MOD -- Shutting down Mod 'wxp'... 10:20:16.91 SPOOGE -- 78.00MB available texture memory 10:20:16.91 SPOOGE -- 78.00MB available texture memory 10:20:17.08 Application closed without errors



IBBoard

Artificer Minoris

50 XP

29th January 2006

0 Uploads

807 Posts

0 Threads

#25 14 years ago

Yeah, your errors are in the following:

10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_infantry' does not exist! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_hq' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_hq_1' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_infantry' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_kasrkin_quarters' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_listening_post' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_list_post_1' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_hq' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_ministorum_temple' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_infantry' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_ogryn_quarters' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_hq' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_telepathica_temple' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_hq' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_turret' pre-requisites! 10:20:00.23 MOD -- Fatal Data Error loading RatioPrerequisite - entity 'ac_hq' does not exist! 10:20:00.23 MOD -- Fatal Data Error for addon 'addon_ac_vindicare_temple' pre-requisites!

I'm not greatly familiar with that phrasing of the error message to be 100% sure of its meaning, but it looks like it can't find the files that you've referenced. For example, if you go to addon_ac_hq_1 then you should find that one of the boxes that should have a value in it (ac_infantry) will actually be empty. Find the box (RatioPrerequisite) and select the correct value in the dropdown and it should work :)




Andon

Armoured Company Addict

50 XP

16th June 2006

0 Uploads

91 Posts

0 Threads

#26 14 years ago

Thanks. I'll look at the normal Guard stuff and copy that, chaniging it to the AC stuff ok, there is no 'ratio_prerequeitie' listing in either the Guard or the AC building listings, or addon listings.




IBBoard

Artificer Minoris

50 XP

29th January 2006

0 Uploads

807 Posts

0 Threads

#27 14 years ago

Hmmmm. Like I said, I've never seen that actual error message before, so I'm not entirely sure.

What have you actually changed? Does the AE error when you re-load the files? What are your addons inheriting from? Which file (addon or unit) do you need to remove for the error to go away? (always a fun part of debugging - remove bits until the error goes away :D)




Andon

Armoured Company Addict

50 XP

16th June 2006

0 Uploads

91 Posts

0 Threads

#28 14 years ago

The AE loads up perfectly fine. I've made sure that the AC is inheriting only from AC. the only thing it's not doing is research, which i don't think i need to copy. And I havn't tried removing anything yet, as there really isn't anything to remove, as i's just the basic guard package modified slightly (Which the modifications worked before i cloned the Guard race, when i first started testing).




Pugman

Your eyes+combat knife=myeyes

50 XP

3rd June 2006

0 Uploads

138 Posts

0 Threads

#29 14 years ago

yeah i had a problem like that, in short you gotta make sure that you have the right reasearch/addons going to the right places, in this it is just easier to copy the research you are going to use from Ig i assume and make it your own eg :addon_guard_ogryn, copy it it and make it :addon_ac_ogryn etc, the problem arises from unfinish/incomplete fields (that most likely doesnt help but i can explain better if you need it, in a notepad or something)




Andon

Armoured Company Addict

50 XP

16th June 2006

0 Uploads

91 Posts

0 Threads

#30 14 years ago

I've already copied the addons. They're all there and set up...