Why oh why is radiant fighting me -1 reply

  • 1
  • 2

Please wait...

Paradox1

Supreme etc

50 XP

10th June 2003

0 Uploads

128 Posts

0 Threads

#1 15 years ago

Ok so I'll quickly go over the story. First I installed jk2 to C:\games\Jedi Outcast. And no recently I've decided that I'd like to learn mapping for jk2 (did a little with UT before). So I got jk2radiant and I installed it in gamedata, and it made a folder inside gamedata called tools, and put itself in there with some other things like modview and so on. Then after about 4 hours of tinkering with it I finally got it to work. Started making a map, then realised that I couldn't bsp it. But sorting out the project settings soon sorted that out. I went away for a little and closed the program. But, now when I come back to it, it can't load any textures at all. So everything goes to the default blue horrible 70's color. My texture path in project settings looks like: C:\games\JEDIOU~1\GameData\base\\textures but it doesn't like it for some reason. Whatever I do doesn't make any textures appear (or even any texture subgroup things like bespin or yavin). Loading textures from a list doesn't work either as only 'Skies' appears as a texture group on that list.

Please can someone help me sort this out? I know you probably get a lot of questions about radiant, but I seem to be the only person with this problem at the moment. Thanks.




aidy1972uk

As Helpful as I can be

50 XP

2nd April 2003

0 Uploads

279 Posts

0 Threads

#2 15 years ago

I can see your radient problem already I think:

Radient doesn't like spaces in file paths so....

copy gamedata folder somewhere else (by doing this you'll keep all your current settings/mods in game)

uninstall game and delete the Jedi Outcast folder

reinstall game to a path with no spaces.

EG: Mine is installed into C:\JK2

Patch the game again then copy gamedata back to the right place.

Open radient and goto file/project settings and change all the paths appropiatly.

I did this when I got into mapping and it worked just fine afterwards.

I should add here that if your going to make new textures for your map then you must remember the no space rule eg: "textures/your map name" is a no-no but "textures/your_map_name" will play nice.

Follow this mapping tutorial to the letter and all should be well.




kylek

Helpful Mind

50 XP

22nd March 2003

0 Uploads

2,158 Posts

0 Threads

#3 15 years ago

Try reinstalling radiant then load your map again then it should work.

My directory for jk2 is: C:\Program Files\LucasArts\Star Wars JK II Jedi Outcast\GameData\base

If thats any help...




tFighterPilot

Force Using Dictator

50 XP

8th April 2003

0 Uploads

3,097 Posts

0 Threads

#4 15 years ago

First, don't listen to aidy

Second, try to change the texture path into C:\games\JEDIOU~1\GameData\\base\textures




Paradox1

Supreme etc

50 XP

10th June 2003

0 Uploads

128 Posts

0 Threads

#5 15 years ago

Well i tried taking all of the advice, and none of it worked :D But don't worry I sorted it. I just extracted the texture folder from assets0.pk3 to the base folder. I shouldn't have to, but it worked so I'm happy. And thanks for all the advice.




Paradox1

Supreme etc

50 XP

10th June 2003

0 Uploads

128 Posts

0 Threads

#6 15 years ago

Well i've just found out that 'sorted' wasn't the right word... Now textures are ok, but it isn't showing shaders ARGH!!! I've extracted the shader folder to base too, but still no luck. Erm help?




Paradox1

Supreme etc

50 XP

10th June 2003

0 Uploads

128 Posts

0 Threads

#7 15 years ago

oh should have said that i'm trying to get to the fog set in the textures menu, but it just isn't appearing on there.




tFighterPilot

Force Using Dictator

50 XP

8th April 2003

0 Uploads

3,097 Posts

0 Threads

#8 15 years ago

Check the Show Shaders check box in the textures window.




aidy1972uk

As Helpful as I can be

50 XP

2nd April 2003

0 Uploads

279 Posts

0 Threads

#9 15 years ago

is the show shaders bit checked at top of texture window?

2nd dumb question:

Since you extracted textures to fix your problem why not try shaders too if the show shaders is checked........?:agreed:




aidy1972uk

As Helpful as I can be

50 XP

2nd April 2003

0 Uploads

279 Posts

0 Threads

#10 15 years ago

LOL!!!!

Just as I clicked submit I got the email notification sound telling me someone else had replied to this forum!! IE it was your answer, tFighetPilot :lol:




  • 1
  • 2