Explosives -1 reply

Please wait...

Cathryn

I'm too cool to Post

50 XP

12th June 2004

0 Uploads

10 Posts

0 Threads

#1 14 years ago

As I'm creating a map with explosives I'm having a problem. Everytime i plant a dyno near it and it explodes the door (the func_explosive) doesnt 'blow up'? Is this a problem in my script or a key/value in the func_explosive (door)




Cathryn

I'm too cool to Post

50 XP

12th June 2004

0 Uploads

10 Posts

0 Threads

#2 14 years ago

Anyone?




Cathryn

I'm too cool to Post

50 XP

12th June 2004

0 Uploads

10 Posts

0 Threads

#3 14 years ago

*bump* Still not fixed and i cant find anything wrong in my map! -_- Every usefull tip is appreciated




nUllSkillZ

GF Pwns Me!

50 XP

13th January 2004

0 Uploads

53 Posts

0 Threads

#4 14 years ago

Can you pleae post your script? Do you have a "script_multiplayer"-entity within your map? With key / value pair: scriptname game_manager Does your func_explosive has a scriptname? Your script should look like ths: game_manager { // game settings } scriptname_of_func_explosive_entity { spawn { wait 200 constructible_class 3 // satchel = 2 / dynamit = 3 } death { // Just put in the correct team and name for the func_explosive wm_announce "Axis have blown up the func_explosive!" } } [edit] Your script must have the name "mapname.script" and it must be in the "maps" subdirectory (/etmain/maps). [/edit]




Cathryn

I'm too cool to Post

50 XP

12th June 2004

0 Uploads

10 Posts

0 Threads

#5 14 years ago

It seems like I deleted my script file -_- But thanks, I'll try immediately. Edit://Doesnt work :( I copied it all and editted it and now looks like this: game_manager

{

// game settings

}

wall1

{

spawn

{

wait 200

constructible_class 3 // satchel = 2 / dynamit = 3

}

death

{

// Just put in the correct team and name for the func_explosive

wm_announce "Allies have blown up the Entrance Door!"

}

}

Anything wrong?




nUllSkillZ

GF Pwns Me!

50 XP

13th January 2004

0 Uploads

53 Posts

0 Threads

#6 14 years ago

Hmm, not sure what the problem is.

First try to add a spawn block to the game manager script block: game_manager { spawn { wait 200 } } wall { spawn { wait 200 constructible_class 3 } death { wm_announce "Allies have blown up the Entrance Door!" } } I assume you have meant wall (you typed walll). Btw the // are only comments. Do you have a "script_multiplayer" entity in your map? Does it have the key / value pair: "scriptname game_manager"? Does your func_explosive have the key / value pair: "scriptname wall"? Is the scriptname value of the entity and the script scriptname identical ( wall / walll )? The following just came to my mind. You must have also a "trigger_objective_info"-entity. You have to give the func_explosive a targetname key: for example: key: targetname value: wall Then create a little brush with origin texture near the func_explosive. Create a brush with trigger texture that surrounds the func_explosive (thats the area where dyn can be planted). Select both brushes right click and select "trigger_objective_info". Then type in the following key / value pairs: key: target value: wall (that's the targetname of the func_explosive) key: track value: the Axis Door (That's the message that is displayed: you are near ...) And you have to select a spawnflag (in your case axis_objective because it can be destroyed by allies / and vice versa). That should work. If not try to add the following key / value pairs: key: targetname value: wall_toi key: scriptname value: wall_toi"




Cathryn

I'm too cool to Post

50 XP

12th June 2004

0 Uploads

10 Posts

0 Threads

#7 14 years ago

I really cant find anything wrong :confused: I put in the map and script file, maybe u can have a look at it.




nUllSkillZ

GF Pwns Me!

50 XP

13th January 2004

0 Uploads

53 Posts

0 Threads

#8 14 years ago

It's working!!! Hmm, not sure what your mistake is. [edit] I'm using Windows XP as OS. I've created a shortcut to start the map. In the target of the shortcut I have: "C:\Programme\Wolfenstein - Enemy Territory\mapping\ET.exe" +set sv_pure 0 +set developer 1 +set g_gametype 2 +set logfile 1 +set g_scriptdebug 1 +devmap castle [/edit]




Cathryn

I'm too cool to Post

50 XP

12th June 2004

0 Uploads

10 Posts

0 Threads

#9 14 years ago

WhaddaĆ½a say! It finally worked for me to.....Straaaaange ET (just like the alien....) but thanks!