Enemy Territory & Vista problems! -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 11 years ago

I just received my new PC// HP a1700n ~ ~ AMD Athlon 64 X2 Dual Core Processor 4200+ 2.20 GHz ~ 1024 DDR2 ~ NVIDIA GeForce 6150 LE (Onboard GPU) ~ Windows Vista Home Premium I wanted to know if anyone has had problems with launching Enemy Territory running Vista or have heard of anything. I keep locking up as soon as the intro starts. When I try to launch it though X-Fire, It locks up when it tries to connect to the server. I have tried shutting down all uneeded background applications and have tried uninstalliing and reinstalling. I have tried running it in compatibility mode and running the application as admin and not. I have updated all hardware and software. No error messages given. Thanks for any imput on this problem. :confused:




Guest

I didn't make it!

0 XP

 
#2 11 years ago

i dont belive that the game is compatible with vista... try putting it on a comp with xp and running the vista upgrade advisor and look in the aplications section.... it will tell you wich applications may not work with it




Pure

Jewel of the Wastes - F3

50 XP

7th July 2006

0 Uploads

153 Posts

0 Threads

#3 11 years ago

No need, ET is not made to work under Vista. All you can do is install the latest videocard drivers and hope it works. The opengl support under vista is not at its best (yet). This because Vista has dx10 in mind which is a Microsoft product, where opengl is not.

Also if you rightclick on et.exe and go to properties, there somewhere you can find compatible mode, see if it works on XP compability. See if there is also a setting that says "run it with administrator rights" or something like that. That is mostly for punkbuster to run hopefully good.

As for the drivers part, (normally I do not recommend this) but you could try newer beta drivers for Nvidia. here you can find the latest official beta driver. Then we have Guru3d.com where one can find newer leaked beta versions.

Still best to wait until Nvidia comes with a workaround to get better opengl support for Vista.




Guest

I didn't make it!

0 XP

 
#4 11 years ago

I have this same problem on a HP DV9000 laptop with GeForce 7600 Go graphics.

I did try upgrading to various Beta drivers. ET will work, but about every 2 seconds, the frames will pause. Otherwise the frame rate is great. The pause is so bad though it's unplayable for me.

Another problem with the beta drivers is that it totally messes up my DVD playback. So I'm waiting for an update from HP. Bummer. I really like ET even though it's so old.




Guest

I didn't make it!

0 XP

 
#5 9 years ago

go to your icon on your desktop, right-click, compitability, run as administrator!

ET must work on vista! (i've vista 2!)