Farcry heads Q? -1 reply

Please wait...

sserega

The Internet ends at GF

50 XP

18th November 2005

0 Uploads

102 Posts

0 Threads

#1 12 years ago

Just installed Farcry do I need to install all the patches or just the last one 1.33 ?




-King-

People say I post too much

50 XP

11th June 2005

0 Uploads

2,370 Posts

0 Threads

#2 12 years ago

Depends on what the patch download says




marvinmatthew

Tech is where you'll find me..

50 XP

13th April 2005

0 Uploads

3,627 Posts

0 Threads

#3 12 years ago

You need 1.1, then 1.2, then 1.3, the 1.33




Guyver VIP Member

Dark System LordResiding In Insanity

41,090 XP

10th November 2004

0 Uploads

3,734 Posts

0 Threads

#4 12 years ago

Moved from General Gaming to Farcry Tech Support and Help.




N88TR

Old school pimp

50 XP

10th February 2004

0 Uploads

9,921 Posts

0 Threads

#5 12 years ago

Only if you play online should you patch to 1.33. 1.31 is plenty good for offline play. There are more than a few issues people encounter in Singleplayer if you patch to 1.33....