Gun refuses to fire -1 reply

Please wait...

Von Mudra

Lo, I am Mudra, za emo soldat!

50 XP

25th September 2004

0 Uploads

7,064 Posts

0 Threads

#1 10 years ago

Me and a couple others in the 130th have noticed an odd bug, in which the gun will not fire when you pull the trigger. This isn't a lag spike or such, as it often happens on our own server, which is only about 50 miles or so away from me. This is it actually not firing at all, causing one to have to release and press the mouse button, losing crucial moments, especially when engaged in close quarter rifle duels. So my question is, is this just a BF2 bug, or an actual FH2 bug, and could it be fixed?

Thanks:)




Flippy Warbear

One of Kelly's Heroes

50 XP

2nd January 2004

0 Uploads

2,600 Posts

0 Threads

#2 10 years ago

Do you fire and keep holding the button at the bottom while the new round hasnt been chambered yet?

If the answer is yes; Indeed, its a feature. You need to release firebutton after each shot to reload it and press the firebutton each time to fire. If you keep the firebutton at the bottom, it wont fire until released (reloaded).

If the answer is no; no idea.




[130.Pz]W.Fuchs

Requiescat in Pace

50 XP

19th March 2008

0 Uploads

4,766 Posts

0 Threads

#3 10 years ago

Sigh.. Get it off safety!! [COLOR=yellow]sorry mudra had to do that.[/COLOR]




Dukat

wasn't around for some years

50 XP

10th June 2004

0 Uploads

552 Posts

0 Threads

#4 10 years ago

Von Mudra;4388900Me and a couple others in the 130th have noticed an odd bug, in which the gun will not fire when you pull the trigger. This isn't a lag spike or such, as it often happens on our own server, which is only about 50 miles or so away from me. This is it actually not firing at all, causing one to have to release and press the mouse button, losing crucial moments, especially when engaged in close quarter rifle duels. So my question is, is this just a BF2 bug, or an actual FH2 bug, and could it be fixed?

Thanks:)

I would not have dared to claim or report that on my own, as I thought it is a problem of mine only. I expirienced that as well. I use rifles most of the time. I got the enemies head centered in my crosshair, and when I click, all it does is...NOTHING. Then I'm totally irritated and delayed, causing the other guy to kill me with ease. Or do the devs call that a feature? Gun-jam?

Edit:// There is a bug known from dice, when you shot at somebody and it doesnt hit. Maybe you found and isolated the bug, leading to a total gun failure/jamming? Just conjecturing.




Guest

I didn't make it!

0 XP

 
#5 10 years ago

sounds like your mouse is broke.




Coca-Cola

[130.Pz.]A.Aussen

50 XP

28th August 2006

0 Uploads

2,816 Posts

0 Threads

#6 10 years ago
Ts4EVER;4389360sounds like your mouse is broke.

Sounds like someone's mouse will have to be relocated to the projects.




Guest

I didn't make it!

0 XP

 
#7 10 years ago
Coca-Cola;4389519Sounds like someone's mouse will have to be relocated to the projects.

I didnĀ“t get that one :lookaround:




General Tso

Head Chump

50 XP

30th September 2003

0 Uploads

206 Posts

0 Threads

#8 10 years ago

I had a weird issue with an 88. It didn't seem to fire even after hitting the mouse button repeatedly. All of a sudden, the tank I'm firing at blows up...and I get credit for the kill. No recoil, sound fx, smoke or anything from the 88. It had a real laggy feel to it, even though I had a low ping and decent latency.




Guest

I didn't make it!

0 XP

 
#9 10 years ago

Did you just enter the flak? the shell needs to be loaded first.




Wilhelm

FH2 betatester

50 XP

27th September 2004

0 Uploads

409 Posts

0 Threads

#10 10 years ago
General Tso;4389545I had a weird issue with an 88. It didn't seem to fire even after hitting the mouse button repeatedly. All of a sudden, the tank I'm firing at blows up...and I get credit for the kill. No recoil, sound fx, smoke or anything from the 88. It had a real laggy feel to it, even though I had a low ping and decent latency.

I get that sometimes, too.

It fires the projectile but gives no indication as such. I also see this a lot when watching other tanks firing. I won't see any smoke or discharge or hear any sound, but the gun has actually fired.