Problem when using Zone Alarm Pro -1 reply

Please wait...

Sgt_Stu_Airvil

I'm too cool to Post

50 XP

3rd January 2003

0 Uploads

1 Posts

0 Threads

#1 15 years ago

Hey there comrades,

Is anyone out there running Zone Alarm Pro Firewall Software whilst playing AAOps??? If so are you experiencing the same problem as me? Problem is as follows: No problems up until i go to update or refresh the list of online games prior to playing a multiplayer game. The game scans about 4-5% of available servers and then the system locks up completely. No Ctl-Alt Del, no mouse movement or keyboard response. Time to reach for the reset button!!!

I have added both Army Ops.exe and server.exe to the list of programs permitted to access the net in Zone Alarm and given them full priveledges. This still does not rectify the problem. Basically the only way to overcome the problem is to shut down Zone Alarm whilst playing, which although not a major issue is something i would prefer to avoid as i have a cable broadband connection and thus dont want to leave my system open to intruders (sounds paranoid i know!!) for hours at a time whilst i'm playing the game. By the way this problem also affects AAO Forward Observer Server location software also??.

Anyone got any clues or can help out i'd be well chuffed.

Cheers folks......




Lawstone

I don't spend enough time here

50 XP

31st December 2002

0 Uploads

22 Posts

0 Threads

#2 15 years ago

Since it is a firewall you need to make sure the appropriate ports are open. If you are blocking access to all incoming address then it will not work. If all your ports are blocked then no one else will be able to see you. Including master servers. Try running zome alarm with the security completely open and vunerable. If it works, then all you have to do is correctly set the security settings. I have problems like this on a network and not being able to gain access to domain controllers because my security was to high.




MiSFiT_MiLiTiA

I don't spend enough time here

50 XP

21st December 2002

0 Uploads

23 Posts

0 Threads

#3 15 years ago

I hate firewalls they always cause problems! I say you get rid of if because I bet everything would work fine once you did! Just don't download anything from anybody unless your scanning it first! I think that firewalls give you a higher ping as well. But if you want to keep the firewall then Lawstone was right makes sure you have certain ports available.




Dark Jedi X

I'm too cool to Post

50 XP

24th November 2002

0 Uploads

1 Posts

0 Threads

#4 15 years ago

I have Zone Alarm Pro to but i have no problems at all




s2ua7

Sealab Slacker

50 XP

5th September 2002

0 Uploads

362 Posts

0 Threads

#5 15 years ago

I am using Zone Alarm. I had that problem. Go in and tell the program to always accept internet connections. This will tell you if thats the problem.

1. Start up AA(while Zone Alarm is running) 2. Get a server list. 3. Once it freezes up run the mouse over the bottom right side of the screen.

If there is a cursor when you move it down there, then your repeat program warning is popping up and you have to check the box that says "Always Allow Access(or something like that)"




DivideByZero

I'm too cool to Post

50 XP

27th September 2002

0 Uploads

2 Posts

0 Threads

#6 15 years ago

Hi Sgt_Stu_Airvil.

I developed Forward Observer with Zone Alarm Pro and play ArmyOps with it up and running.

For both programs, you have to add them to ZA's program list. I have the 'Access' and 'Server' settings set to 'Allow' for both Trusted and Internet Zones. If you right click FO and ArmyOps and select Options, make sure that 'Allow Access to all ports and Protocols' is selected.

I also have Program Control set to Medium.

Hope this helps.

DBZ




kop48

I'm too cool to Post

50 XP

19th March 2003

0 Uploads

2 Posts

0 Threads

#7 15 years ago

I had a think about what s2ua7 said, and double checked my AAO settings to make sure that it HAD server access. It did, so i reran the application, but clicked on the button next to the exit button (top right, little rectangle) which makes AAO run in a window. Sure enough when I tried to refresh the server list, it popped up a ZA thingie asking for permission. I don't know why it didn't accept my settings in the first place, but it works all the time now ( I don't need to go to window mode any more - ZA remembers my settings) ....

So that's what I had to do :) enjoy




Peeping Tom

I take what n0e says way too seriously

50 XP

1st March 2003

0 Uploads

2,619 Posts

0 Threads

#8 15 years ago

I have Norton Internet Security 2002 and I have issues. I allow AAO access to the net but it still doesn't work! Any specific ports/ips gotta be open? maybe gamesnetusa.com (which holds your stats, according to internal game files) has to be open......




Guest

I didn't make it!

0 XP

 
#9 13 years ago

Look at this link ..I have a simular problem http://aaotracker.4players.de/thread.php?postid=953721#post953721 I cant list up the serverlist in AA... Only one server is showing and the listing seems to stop at 1-2% it takes long time, and then he stops there are only ??? in every serverwindow I have WIN XP Pro SP2 "FIREWALL OFF" Agnitum Outpost 2.1 "FIREWALL ACTIVE" AA-game VER. 2.2.1 IF this would be a firewall problem, why can i see the 1-2 servers but not the rest? Can anyone tell me how to config this firewall? I have tried to shut the firewall of and use XP own... still the same... I will not try to disable both, ill have fresh memory about what happend last time... :) My hair will be grey of this problem... "hmm,,everybody+s talking the technic is going forwards, i´ll will mean that the technic sometimes go1 step forward and two back again" Anyway.. I chosed to display all servers, like miles, official and so on.... I have gived armyops.exe all permission in firewall, and same problem.... I did find this on internet ... I NEED TO KNOW IF IT IS INBOUND/OUTBOUND? IS IT REMOTEPORT or LOCALPORT? ***************************** A: UDP ports 1716 for the game, 1717 for the gamequery, 1718 for master server query, 8777 for standard UT query, 27900 for GameSpy and TCP 20045 for Auth server. UDP - 1716, 1717, 1718, 8777, 27900 TCP - 20045, 14200