2.15 full -1 reply

Please wait...

Guest

I didn't make it!

0 XP

 
#1 10 years ago

hi i downloded the full mod 2.15 when i try to join a server it says ive got a older version is there a patch ive missed




LIGHTNING [NL]

FH2 Developer

50 XP

30th May 2003

0 Uploads

9,811 Posts

0 Threads

#2 10 years ago

When you get an error saying you do not have the latest version it means you do not have the latest version of Battlefield 2.

If you had a wrong version of FH2 you would simply crash.




Apo-TTCC

FH2 Betatester

50 XP

27th October 2005

0 Uploads

716 Posts

0 Threads

#3 10 years ago
graemo;4797893hi i downloded the full mod 2.15 when i try to join a server it says ive got a older version is there a patch ive missed

Simply means BF2 is not up to date. Get the full 1.41 patch and install it.

Battlefield 2 v1.41 Patch