BF2 won't patch- Need Help!! -1 reply

Please wait...

Matthew Baker

The forums staffers think I'm Cool

50 XP

7th May 2007

0 Uploads

155 Posts

0 Threads

#1 10 years ago

This is a very unusual problem that ive had so i really need somebody's help and so far ive gotten nothing. Ive installed bf2 after a long time of inactivity and i go to patch it, but the patching would always stop and tell me that patching failed. So after researching the problem i tried continuesly trying to patch until it worked. Which it did. The patch would go and then it would say after patching complete and i would start up the game. But.... I do not have Highway tampa and i always get kicked by pb for a very odd reason (i forget the exact message. If its important, i can post it up later if needed.). At this time I realized that the patching didn't finish. It stops right after road to jalalabad and claims it's complete. If anybody has a way to make it patch completely, or has the files i need to do it manually that would be greatly appreciated.




Eat Uranium

Wyrd bið ful ãræd

50 XP

12th July 2008

0 Uploads

646 Posts

0 Threads

#2 10 years ago

Highway Tampa was not in the 1.41 patch (it was a stand alone map). Try downloading and running PBsetup.exe. That might be the cause of the error. Also, if you're using Vista, make sure you run everything in XP mode with admin.




Matthew Baker

The forums staffers think I'm Cool

50 XP

7th May 2007

0 Uploads

155 Posts

0 Threads

#3 10 years ago

Stupid me.... Okay I just wanted to make sure because i didnt want to download FH if i didn't have a fully up to date BF2. Ill try now.




Apo-TTCC

FH2 Betatester

50 XP

27th October 2005

0 Uploads

716 Posts

0 Threads

#4 10 years ago

Just check out the BF2 version number in the lower left corner of the login screen or the upper right corner of the main menu. If it reads '1.1.2965-797.0' it means the latest patch 1.41 was applied and you are good to go.




Matthew Baker

The forums staffers think I'm Cool

50 XP

7th May 2007

0 Uploads

155 Posts

0 Threads

#5 10 years ago

Thanks guys got it working :D. Really appreciate the quick help