"Your Version is Older Than the Server's" -1 reply

Please wait...

3FJ_Adler

I'm too cool to Post

50 XP

24th August 2008

0 Uploads

12 Posts

0 Threads

#1 10 years ago

I just spent 3 or 4 hours last night reinstalling BF2 and FH2 after moving away from my computer for 4 or 5 months. Everything is a fresh install and i'm up to BF2 1.41 and FH2 2.1. However, whenever i try to join a server is gives me the message: "Your version is older than the server's" Am I missing something here??




Apo-TTCC

FH2 Betatester

50 XP

27th October 2005

0 Uploads

716 Posts

0 Threads

#2 10 years ago

Usually a problem that shows up when BF2 is not up to date. Make sure you really got the 1.41 full patch, reapplying it might also help since somtimes the patch will not install properly even if it is not saying so. An up to date BF2 1.41 installation has this version number shown ingame, mainmenu upper right corner:

1.1.2965-797.0

If the number is different you need to get the 1.41 full patch, because in the past it turned out that many people with this problem just had the 1.4 patch installed (by checking the version number ingame).




3FJ_Adler

I'm too cool to Post

50 XP

24th August 2008

0 Uploads

12 Posts

0 Threads

#3 10 years ago

rgr thanks. I'm re-downloading 1.41 to make sure i have the correct one then i'll re-reapply it. :D




[FtN|GT] Die Happy

FH2 Betatester

50 XP

19th February 2007

0 Uploads

894 Posts

0 Threads

#4 10 years ago

hey adler are you the guy from the teamspeak i talked to yesterday ? if yes sorry you didnt get it working yet

as apo said i still think you somehow dont have the right bf2 version keep patching until your version number matches this one: 1.1.2965-797.0 maybe you are using some kind of restricted windows xp user ? or do you have admin privileges ?

well hope you get it working and welcome to the forums, feel free to look around and post stuff but restrain using words like "Maus" "Ratte" "Pershing" and "Lafette" as long as you dont wear any asbestos clothing ;)




3FJ_Adler

I'm too cool to Post

50 XP

24th August 2008

0 Uploads

12 Posts

0 Threads

#5 10 years ago

patching to 1.41 failed for some reason. then, after i hit ok it said BF2 was patched successfully. guess i'll have to reinstall everything later tonight after dinner if i can find time.




3FJ_Adler

I'm too cool to Post

50 XP

24th August 2008

0 Uploads

12 Posts

0 Threads

#6 10 years ago

reinstalled the patch, said it patched successfully. started the game and it's still showing 1.1.2940-797.0...or something to that effect. it doesn't match up with the newest code.

so far i've applied the patch 4 times, each time saying it was successful in the end...but in-game it acts like the patch never happened. god i hope i don't have to uninstall and reinstall...

will try again after dinner.




Admiral Donutz VIP Member

Wanna go Double Dutch?

735,271 XP

9th December 2003

0 Uploads

71,460 Posts

0 Threads

#7 10 years ago

Where did you got the patch from?

The one on filefront and/or bf2files.com should work. I got my patch from there (I think) but that has been in late 2007).




Apo-TTCC

FH2 Betatester

50 XP

27th October 2005

0 Uploads

716 Posts

0 Threads

#8 10 years ago

This is the complete BF2 version history:

The version numbers are as listed below:
  • Un-updateed game.
  • 1.0.2442.0
Version 1.01 update installed. 1.1.2475.0 Version 1.02 update installed. 1.1.2484.0 Version 1.03 update installed. 1.1.2551.0 Version 1.12 update installed. 1.1.2254-356.0 Version 1.2 update installed. 1.1.2696-528.0 Version 1.21 update installed. 1.1.2716-548.0 Version 1.22 update installed. 1.1.2716-552.0 Version 1.3 update installed. 1.1.2878-710.0 Version 1.4 update installed. 1.1.2963-795.0 Version 1.41 update installed. 1.1.2965-797.0



3FJ_Adler

I'm too cool to Post

50 XP

24th August 2008

0 Uploads

12 Posts

0 Threads

#9 10 years ago

i got the patch from strategy informer..link on the official BF2 site. based on that version history, it looks like it's thinking it's an un-updated version. I'll try re-installing 1.4 full.

btw thanks for all the help guys, this is awesome!




3FJ_Adler

I'm too cool to Post

50 XP

24th August 2008

0 Uploads

12 Posts

0 Threads

#10 10 years ago

no luck. i think i've FUBAR'd it. i'm gonna have to do a complete reinstall tomorrow.